Help! Water Temp 105 after 5 min!

Discussion in 'RE Club Malaysia' started by visualpimp, Apr 8, 2011.

  1. visualpimp

    visualpimp 15 Year | Platinum

    Joined:
    Sep 17, 2007
    Messages:
    12
    Likes Received:
    0
    Hi all, need help. Car water temp shot up to 105degrees C after just 5min of driving. Dunno what happen.
     
  2. xtremeleo

    xtremeleo Senior Member
    Senior Member

    Joined:
    Oct 18, 2005
    Messages:
    3,245
    Likes Received:
    463
    jammed thermostat?
     
  3. phat7

    phat7 Senior Member
    Senior Member

    Joined:
    May 21, 2004
    Messages:
    2,122
    Likes Received:
    62
    Sounds right.
     
  4. kariayam

    kariayam Senior Member
    Senior Member

    Joined:
    Oct 3, 2007
    Messages:
    191
    Likes Received:
    48
    jammed thermostat, fan failure, how about water level?
     
  5. xtremeleo

    xtremeleo Senior Member
    Senior Member

    Joined:
    Oct 18, 2005
    Messages:
    3,245
    Likes Received:
    463
    cudnt have been the fan, the car was in motion. might have been the water level
     
  6. Tom

    Tom 15 Year | Platinum
    Helmet Clan

    Joined:
    Jul 6, 2000
    Messages:
    5,276
    Likes Received:
    3,113
    faulty thermostats can raise water temps in seconds
     
  7. RERider

    RERider Moderator

    Joined:
    Aug 7, 2004
    Messages:
    2,756
    Likes Received:
    104
    make the thermostats a couple of hole....
     
  8. malimsiao

    malimsiao Senior Member
    Senior Member

    Joined:
    May 5, 2008
    Messages:
    88
    Likes Received:
    14
    since u are checking ur thermostats, it is recommended to flush ur radiator amd together with some modding for example change your radiator to aluminum/copper 2-3 core (if u are stil using the stock radiator) to increase reliability. my 2 cent
     
  9. underslyder

    underslyder 5 Year | Silver

    Joined:
    Dec 27, 2010
    Messages:
    64
    Likes Received:
    3
    mine has a more funny problem. I am not sure whether it is the meter problem or sensor problem. When i start my car after 5 seconds the water meter warning comes out with that sound. Water temp on both my defi and stock meter appears to be normal even after driving. So now need to check whether is the meter problem or sensor. Am i right sifus? i am not sure what else to do already
     
  10. RERider

    RERider Moderator

    Joined:
    Aug 7, 2004
    Messages:
    2,756
    Likes Received:
    104
    low water level
     
  11. underslyder

    underslyder 5 Year | Silver

    Joined:
    Dec 27, 2010
    Messages:
    64
    Likes Received:
    3
    water level perfect. Based on your experience Rerider is there other things that can trigger a warning light and sound but the water temp is normal? even during traffic jam it is normal but sound still there.
     
  12. xtremeleo

    xtremeleo Senior Member
    Senior Member

    Joined:
    Oct 18, 2005
    Messages:
    3,245
    Likes Received:
    463
    i guessing the std meter is fecked up, since the other meters are showing good reading. please clarify by installing another std meter and report back
     
  13. underslyder

    underslyder 5 Year | Silver

    Joined:
    Dec 27, 2010
    Messages:
    64
    Likes Received:
    3
    well bro , changed to another meter still got sound, is it the sensor then? which sensor is that?
     
  14. xtremeleo

    xtremeleo Senior Member
    Senior Member

    Joined:
    Oct 18, 2005
    Messages:
    3,245
    Likes Received:
    463
    okie, what sound eh? anyway, sounds like the sensor is fecked. shud be easy to find and replace tu
     
  15. Rock Lee

    Rock Lee Senior Member
    Senior Member

    Joined:
    Oct 18, 2004
    Messages:
    3,972
    Likes Received:
    25
    is yur coolant level low? maybe its beeping for the coolant tank.
     
  16. phat7

    phat7 Senior Member
    Senior Member

    Joined:
    May 21, 2004
    Messages:
    2,122
    Likes Received:
    62
    We have a water level sensor on the neck. Check that. Its a single wire and replacement is easy.
     
  17. visualpimp

    visualpimp 15 Year | Platinum

    Joined:
    Sep 17, 2007
    Messages:
    12
    Likes Received:
    0
    probably a jammed thermostat. Will send in the car for a radiator flush while at it just in case. Thanks alot Sifus here. Hope that will help.
     
  18. Brew

    Brew 5 Year | Silver

    Joined:
    Apr 7, 2011
    Messages:
    37
    Likes Received:
    1
    I am getting the same thing. Water temp reading is at half when warning light and sound is on. however, i have some slight wiring issues that sometimes the warining light and sound comes on and sometimes it does not. this goes the same for the mileage display..it comes and go..i gotta get the wiring for that part rectified.
     
  19. underslyder

    underslyder 5 Year | Silver

    Joined:
    Dec 27, 2010
    Messages:
    64
    Likes Received:
    3
    Brew,

    Yeaps its wiring problem. I have confirmed this point with mechanic already.
     
  20. Brew

    Brew 5 Year | Silver

    Joined:
    Apr 7, 2011
    Messages:
    37
    Likes Received:
    1
    Thanks for the confirmation bro. I've checked my coolant and apparently it needs refilling as well hehe.
     

Share This Page