Alignment problem on 4g93 mivec

mizi0604

Known Member
Senior Member

mizi0604

Known Member
Senior Member
Nov 6, 2008
179
6
1,518
Hi all sifus...

I need help from u guys,i'm facing an alignment problem with my car for quite a long time...My car tend to go right when i pushed the pedal even my steering was straight and it will go straight when i released the pedal...I've sent my car for alignment for many time and still not solve...I become headache while driving because my car going straight but i hold the steering a few degree to left..:stupid::stupid::stupid:

-Really appreciate if you guys can help me to solve this problem...:bawling:
 

risyia

Known Member
Senior Member

risyia

Known Member
Senior Member
Feb 16, 2005
168
30
3,028
Pandan Indah
If u have replaced only one of the CV joint, it may also cause this problem - car pulling to one side under acceleration.

It has something to do with the new 'tighter' CV joint transferring more torque to that particular wheel under acceleration.
 

mizi0604

Known Member
Senior Member

mizi0604

Known Member
Senior Member
Thread starter
Nov 6, 2008
179
6
1,518
suspect stabiliser bar bushes worn out...
tie rod end & lower arm could be the culprit as well.
Ok thanks...will ask my pomen to check all these things...

---------- Post added at 03:33 PM ---------- 6 hour anti-bump limit - Previous post was at 03:28 PM ----------

If u have replaced only one of the CV joint, it may also cause this problem - car pulling to one side under acceleration.

It has something to do with the new 'tighter' CV joint transferring more torque to that particular wheel under acceleration.
I haven't changed my CV joint yet...Might any other cause for this problem???
 

risyia

Known Member
Senior Member

risyia

Known Member
Senior Member
Feb 16, 2005
168
30
3,028
Pandan Indah
another possible reason are the tyres, had that problem once after changing to new tyres. The foreman had to swap left wheel with right wheel, also did not solve the problem. In the end had dismount it & refitted again in a 'swap' position, then only solve the problem. Maybe bunga punya pasal...
 

mizi0604

Known Member
Senior Member

mizi0604

Known Member
Senior Member
Thread starter
Nov 6, 2008
179
6
1,518
i just asked my pomen to check , he said maybe my suspension out for 1 side...
 

boyzone

2,000 RPM
Senior Member

boyzone

2,000 RPM
Senior Member
Mar 13, 2005
2,669
38
3,148
How many Tyre shop u had been visited?
I had been face this issue on my mivec as well, at last, they manage to solve the problem via offset the rack. Hope can help.