Proton wira 1.5 (1997 auto) distributor problem

arifsobhan85

Junior Member

arifsobhan85

Junior Member
Oct 27, 2014
9
1
503
Kajang
two months before, one day engine of my wira car suddenly stopped. I consulted a mechanic and according to his suggestion i changed/ replaced distributor and he took RM 230 for that and gave me 3 months warranty. Suddenly, last week i also got same problem, whenever i press accelerator, it seemed that the engine is not getting power and after 5 minutes the car stopped again. I consulted the same mechanic as i had the warranty, he replaced a new distributor. again i got the same problem after 5 days.

One more thing to include that my car has auto lock and from last month it is not working properly, sometimes works and some time do not work. so, i disconnected it.

Can any expert help me to find out why this is happening?

Is there any chance to affect other components due to this problem?
 

gunnerzz

2,000 RPM

gunnerzz

2,000 RPM
Jul 3, 2014
2,080
677
713
36
Melaka
if not mistaken rm230 is for a reconditioned distributor right?
thing is with recon part,its like a gamble.

happen to me once on a pajero.change once,jerking.
change again,fine.

there is a resistor inside the distributor.most of the time the recon factory didnt replace it during the recon process.
not many shop carry the resistor as malaysian tend to change the whole assembly.
 

arifsobhan85

Junior Member

arifsobhan85

Junior Member
Thread starter
Oct 27, 2014
9
1
503
Kajang
Thank you for your advice. I have one more thing to know:

Is there any chance to spoil the distributor because of electrical circuit problem?
 

gunnerzz

2,000 RPM

gunnerzz

2,000 RPM
Jul 3, 2014
2,080
677
713
36
Melaka
Nope,its a stand alone unit on your car model.
Newer car uses pencil coil or coil pack with individual wiring which if messed up can be tricky to diagnose.

double check the wiring involving the distributor which include the pkugs cable see if any is crack causing current leak.
if not then its fine.
 
Last edited:

Izso

NA NA NA NA NA
Helmet Clan
Moderator

Izso

NA NA NA NA NA
Helmet Clan
Moderator
Mar 28, 2004
15,334
6,400
5,213
KL
This is a long shot but did you have a frontal accident in the past? Perhaps your cars grounding is faulty? Hence the central locking issue.

As for the distributor frying, not that easy to fry. Did the mechanic check the spark plugs? Sometimes a faulty disti will end up fouling the plug and those will be clogged or faulty.
 

arifsobhan85

Junior Member

arifsobhan85

Junior Member
Thread starter
Oct 27, 2014
9
1
503
Kajang
Thank you for your suggestion. However, i bought the car one year before in august 2013 and since then there was no problem. Last july 2014, i went to terengganu with this car and in kuantan highway my engine got heated because of radiator problem and i fixed it in kuantan. After that in august 2014, suddenly my distributor spoiled and i changed it. now this week i have to change the distributor twice (as i have warranty). So, i am worried if it continues, i have to pay more but the main problem is i may face very awkward situation in the road like this week.

Anyway according to your suggestion i will replace the plugs. Thank you once again for your help.

---------- Post added at 05:19 PM ---------- 6 hour anti-bump limit - Previous post was at 02:38 PM ----------

Your anticipation was right. I got 2 plugs spoiled already. I changed the plugs as well as the wires. Thank you for sharing your experience.
 
Mar 25, 2015
4
0
501
Kuala Lumpur
Hi, I would like to know where there any solution for my car with problem at below:
Proton Wira 1.5 Auto 1999
The issue I having here is the car can't start. The car drive for 5min, stop the car (around 5min) then the car can't start. Then need to wait for 10 to 20min lets the engine cool down, the car will start again, once the car start, the car can drive smoothly without any issue. Only when stop for petrol the issue come again. Already try 3 mechanic, the problem still remain......:s::s::s:
 

Izso

NA NA NA NA NA
Helmet Clan
Moderator

Izso

NA NA NA NA NA
Helmet Clan
Moderator
Mar 28, 2004
15,334
6,400
5,213
KL
Hi, I would like to know where there any solution for my car with problem at below:
Proton Wira 1.5 Auto 1999
The issue I having here is the car can't start. The car drive for 5min, stop the car (around 5min) then the car can't start. Then need to wait for 10 to 20min lets the engine cool down, the car will start again, once the car start, the car can drive smoothly without any issue. Only when stop for petrol the issue come again. Already try 3 mechanic, the problem still remain......:s::s::s:
When you can't start - does it crank? Or no cranking noise at all? Give more description la. What have you done to the car? Eagle eye headlamps? (Known to be big time ampere suckers) anything replaced with recon parts recently? Mods? Give more details.