Restoration of Satria 1.3

cIvIc_noob

Known Member
Senior Member

cIvIc_noob

Known Member
Senior Member
May 22, 2005
62
0
3,006
Miri
Hi guys,

i have a one speed all the way wiper problem.

I've even bought and swapped out the whole wiper/signal control. problem still persists.

I read up more and it says could be a relay problem, could someone point out to me with a pic of the relay location?

i PM'ed a seller at shopee, mentioned that normally it is at linkage, I don't think so from my googling. So i went to look at the wiper motor side but couldn't find it.

I looked at the fuse box and i am confused.

So where exactly is it?
 

gunnerzz

1,500 RPM

gunnerzz

1,500 RPM
Jul 3, 2014
1,860
596
713
35
Melaka
Hi guys,

i have a one speed all the way wiper problem.

I've even bought and swapped out the whole wiper/signal control. problem still persists.

I read up more and it says could be a relay problem, could someone point out to me with a pic of the relay location?

i PM'ed a seller at shopee, mentioned that normally it is at linkage, I don't think so from my googling. So i went to look at the wiper motor side but couldn't find it.

I looked at the fuse box and i am confused.

So where exactly is it?
Switch on your wiper or turn signal and listen for the relay 'tik2' sound. Trace the origin for that sound and you will find it.
I think its at driver side under the dashboard. It should be visible when u peek from the bottom.
 

Izso

Boooooossst
Helmet Clan
Moderator

Izso

Boooooossst
Helmet Clan
Moderator
Mar 28, 2004
14,908
6,278
5,213
KL
Hi guys,

i have a one speed all the way wiper problem.

I've even bought and swapped out the whole wiper/signal control. problem still persists.

I read up more and it says could be a relay problem, could someone point out to me with a pic of the relay location?

i PM'ed a seller at shopee, mentioned that normally it is at linkage, I don't think so from my googling. So i went to look at the wiper motor side but couldn't find it.

I looked at the fuse box and i am confused.

So where exactly is it?
Engine bay I think. That's the only place that has those large relays for Wira.

 

sanekit

1,500 RPM

sanekit

1,500 RPM
Dec 9, 2015
1,597
153
163
Petaling Jaya
Hi guys,

i have a one speed all the way wiper problem.

I've even bought and swapped out the whole wiper/signal control. problem still persists.

I read up more and it says could be a relay problem, could someone point out to me with a pic of the relay location?

i PM'ed a seller at shopee, mentioned that normally it is at linkage, I don't think so from my googling. So i went to look at the wiper motor side but couldn't find it.

I looked at the fuse box and i am confused.

So where exactly is it?
it's inside the fuse box under your steering column. the box supposed to have a label on the cover.
 

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator
May 11, 2010
29,451
8,232
1,713
Petaling Jaya
it's inside the fuse box under your steering column. the box supposed to have a label on the cover.
Fuse box got relay? I think what bro. Izso mention in engine bay, the main fuse box have relays in them.....
 

sweelt

2,000 RPM

sweelt

2,000 RPM
Nov 6, 2016
2,240
227
163
Penang
Fuse box got relay? I think what bro. Izso mention in engine bay, the main fuse box have relays in them.....
Key ON (not start engine), Activate wiper, listen to which relay clicking/ feel by finger. I use this method as last resort.
 

gunnerzz

1,500 RPM

gunnerzz

1,500 RPM
Jul 3, 2014
1,860
596
713
35
Melaka
Hi guys,

i have a one speed all the way wiper problem.

I've even bought and swapped out the whole wiper/signal control. problem still persists.

I read up more and it says could be a relay problem, could someone point out to me with a pic of the relay location?

i PM'ed a seller at shopee, mentioned that normally it is at linkage, I don't think so from my googling. So i went to look at the wiper motor side but couldn't find it.

I looked at the fuse box and i am confused.

So where exactly is it?
Manage to find it?
 

cIvIc_noob

Known Member
Senior Member

cIvIc_noob

Known Member
Senior Member
May 22, 2005
62
0
3,006
Miri
Switch on your wiper or turn signal and listen for the relay 'tik2' sound. Trace the origin for that sound and you will find it.
I think its at driver side under the dashboard. It should be visible when u peek from the bottom.
Thanks for telling Me there are relay there, but i Dont hear tik tik tik sound when i turn the wiper on.

Is there a possibillity if there was no relay there in the first place there wont be tik tik sound?
 

cIvIc_noob

Known Member
Senior Member

cIvIc_noob

Known Member
Senior Member
May 22, 2005
62
0
3,006
Miri
Engine bay I think. That's the only place that has those large relays for Wira.

Doesnt seem Like it bro , i googled the relay pic , And i Check engine bay Area at the small relay box on left And also the fuse box on right , nothing looks Like it .
 
Last edited:

cIvIc_noob

Known Member
Senior Member

cIvIc_noob

Known Member
Senior Member
May 22, 2005
62
0
3,006
Miri
Key ON (not start engine), Activate wiper, listen to which relay clicking/ feel by finger. I use this method as last resort.
Oh use finger, haha ok i try find with This technique, but i am afraid if the previous owner removed it then there wouldnt be tik tik sound
 

cIvIc_noob

Known Member
Senior Member

cIvIc_noob

Known Member
Senior Member
May 22, 2005
62
0
3,006
Miri
View attachment 576311

Try this one. It may be it
Looks very probable bro, tonight i go check it out, that day i took picture macam nothing there, but there are a few loose connectors here And there too. So tonight i Go Check if anything there. The wiring below is a nightmare.
 

Attachments