[HELP]Weird Noise Coming from Engine

infinity.melvin

SlowPoke
Senior Member

infinity.melvin

SlowPoke
Senior Member
Jul 4, 2006
1,600
153
1,663
kuala lumpur
[HELP]Exhaust Manifold (extractor) Gasket Problem!

hi guys, been having this problem recently. Weird rubbing/squelling-a-like noise from the engine bay (sounds like "jit jit jit jit" or "chit chit chit chit").
ONLY appear when engine is warmed up! sound is suspected to be coming from belt & pulley area.

✔ Already checked and changed all 3 v-belts (alternator, power steering & crank pulley belt).
✔ Checked all pulleys, no wobbling or loose pulley. No apparent misalignment of belts or pulley

Sounded loud and significant with lightened crank pulley installed (been using Works Engineering LCP since few months ago, but sound only recently appeared).

currently already swapped out back to original stock crank pulley. sound lesser, but still having the weird sound coming out when engine fully warmed up.

no sound at all when engine is cold, or during accelerating.
sound only apparent during stand still/idling.

so far, few times heard the noise when compressor kicks in (yet to 100% confirm, sometimes also got sound when compressor not kicking in)

not sure if its got to do with the alternator/compressor pulley bearings or something related to that.

sifus PLS HELP! :bawling:
Car : Perodua Viva Elite 1.0 Auto
 
Last edited:

Katsumoto

Active Member

Katsumoto

Active Member
Nov 19, 2011
37
43
518
Kuala Lumpur
do me a favor try drive the car without the a/cond on , then see if the sound still there or not

and pls notice if the sound increase when the rpm of the engine increase or not.

A) if the sound still there then probably is belt tensional bearing (i m not so sure you have 1 or not) or alternator bearing

b)if the sound is GONE when the a/cond is off then most probably is a/cond compressor bearing or a/cond magnetic coil + clutch set is worn out (if is the magnetic coil + clutch set worn out try to ask a friend inside the car rev the engine till 4-5k rpm with the a/cond running , most probably you will see sparks coming between magnetic coil + clutch set . if this the case 100% confirm both KO already)
 

nyantong

Known Member
Senior Member

nyantong

Known Member
Senior Member
Jul 26, 2008
192
50
1,528
I've once encountered a case whereby the aircond compressor pulley was making noise whether or not it was activated. The best way to determine whether its the aircond is to actually remove all belts and rotate by hand each and every pulley to see if any wobbles or feels rough.
 

infinity.melvin

SlowPoke
Senior Member

infinity.melvin

SlowPoke
Senior Member
Thread starter
Jul 4, 2006
1,600
153
1,663
kuala lumpur
Today I've tried driving without ac on. Sound is still there..
And aircond not feeling cold as usual, so I went to sanden to service. Apparently compressor seal leaking, got it replaced n fixed.

But my noise issue is still haunting me :(
 

infinity.melvin

SlowPoke
Senior Member

infinity.melvin

SlowPoke
Senior Member
Thread starter
Jul 4, 2006
1,600
153
1,663
kuala lumpur
Currently when engine not warm also make noise already. But off and on only will hv the noise. According to my mech it could the compressor bearing too. He ask to change the whole compressor.. But he too is not 100% sure.. I'm just worried is other issue.

I've read online some say can fix by just changing the bearing?

Btw, what is tensioner? Perodua viva have??
This one is associated with timing belt isnt it?

Still in dilemma on this problem. Any good foreman to recommend on this problem?
 

infinity.melvin

SlowPoke
Senior Member

infinity.melvin

SlowPoke
Senior Member
Thread starter
Jul 4, 2006
1,600
153
1,663
kuala lumpur
solutions found~! water pump was abit problematic, pulley was rough. got that changed with timing belt to save labour charges.. since its just another few k KM to change.

after changing that, noise seems to lessen but still got the annoying "chit chit chit" sound but this time coming from the engine section.
played 'teka-teki' and found out its the exhaust manifold gasket ring. changed to a new thick one as the old one already makan, thus having freeplay and squeaks when exhaust vibrates! quite common among 3-cyclinder cars, kcars etc. so nxt time u have unresolved rubbing/squeaking noise from the engine bay, remember to check your exhaust

thumbs up for JC auto performance @ The Strand Kota Damansara for fixing my problem! :)
 
Last edited:

infinity.melvin

SlowPoke
Senior Member

infinity.melvin

SlowPoke
Senior Member
Thread starter
Jul 4, 2006
1,600
153
1,663
kuala lumpur
argh! after a happy 1 week+ of problem solved, the sound apparently is coming back again. now starting to have some minimal sound coming back when exhaust is warmed up... so fast the gasket ring worn out.

could it be my exhaust manifold flange not even? thus cant be bolted down nice & flat? the gasket so fast KO
 

stephensim9380

Junior Member

stephensim9380

Junior Member
Jan 6, 2013
5
0
501
Sarawak
Recently my car also have the same problem. So I go to Perodua SC to check. The Mech say is Alternator problem. Need to change, some more cost RM800+. But today when I drive my car, the sound seems gone. Donno what happen to this viva. Seems alot of problem. I've been fixing this and that for so many time. Can't even peace for a month.