boost meter reading

rorytate

4,000 RPM
Senior Member
Joined
Nov 17, 2003
Messages
4,417
Points
3,138
Good day all,

My car got out about 3 weeks ago, made some changes on it.

Well, now my boost reading is zero(0) when idling, when throttle a little, it goes down....then if boost it goes up a little...

what is going on???

Also would like to know if there's any difference on NA and Turbo throttle body.

The boost meter is in working condition as i tested with few other units of meter, and it's showing the same sign.

Even if i hose it straight from the throttle body hose, still reading the same sign.

Please enlighten me all Cfus
 
idle reading at 0?? i think ur hosing to the gauge salah liao. cannot be no vacuum at idle ma.

rorytate said:
Good day all,

My car got out about 3 weeks ago, made some changes on it.

Well, now my boost reading is zero(0) when idling, when throttle a little, it goes down....then if boost it goes up a little...

what is going on???

Also would like to know if there's any difference on NA and Turbo throttle body.

The boost meter is in working condition as i tested with few other units of meter, and it's showing the same sign.

Even if i hose it straight from the throttle body hose, still reading the same sign.

Please enlighten me all Cfus
 
well i dont think i'm doing it the wrong way lor. Coz as i mentioned, i even connect it at the main joint at the throttle body
 
fren...
no diff in throttle body come turbo or n/a
usually a boost meter will indicate zero if u turn off the ignition. when u start ur car it will indicate negative. then when u just tap the accelerator it should rise up to zero & barely go up further unless ur 'on gear' accelerating

maybe u sourced out the input wrongly....

just sharing
 
try to connect your hose some where else lor.... eg. after throttle body..
 
want to ask silly question, how to read boost meter? I noticed when throttle then turbine signal on, and my boost reading at 0.7. Is tat tell me my EVO boost at 0.7? I m using Blizt boost meter. For how long I can keep this turbine signal on? 1 km ok?
 
crocky said:
want to ask silly question, how to read boost meter? I noticed when throttle then turbine signal on, and my boost reading at 0.7. Is tat tell me my EVO boost at 0.7? I m using Blizt boost meter. For how long I can keep this turbine signal on? 1 km ok?

yaya..tat mean ur evo running at max boost 0.7bAr

keep d max boost by tekan all ur accelaration pedal.....easy..ehaha
 
oh..yalo...u running wat car wit wat engine a? if tat is NA engine..full throtle sure is at '0'



rorytate said:
Good day all,

My car got out about 3 weeks ago, made some changes on it.

Well, now my boost reading is zero(0) when idling, when throttle a little, it goes down....then if boost it goes up a little...

what is going on???

Also would like to know if there's any difference on NA and Turbo throttle body.

The boost meter is in working condition as i tested with few other units of meter, and it's showing the same sign.

Even if i hose it straight from the throttle body hose, still reading the same sign.

Please enlighten me all Cfus
 
guys thanks for the input...

not NA, running a hybrid gsr...

usually at idling, it's -ve 0.5...of course off engine it's at 0 la...boost kicks in when you engage gear and ramm la...those i know...

i changed block few weeks back...and this is what i get...no point tapping at other vacumn as even on the throttle body itself is already zero(0) at idling??

any suggestions?
 
have u tried driven ur car?? does it kick like usual? hows the condition of ur turbine?

u changed block or head? im assuming ur hybrid gsr is mivec turbo??
 
Golfer said:
Hello all. Am new to forum.
rorytate - Out of curiosity, what boost gauge are you using?

as wat rorytate mentioned..it doesnt related with d boost meter...so i guess it will be other problems...

Rorytate....after u changed ur block...so now ur car running in good condition? but imposible ur boost reading at '0'.....so weird....unless ur turbo didnt kick on
 
u should tap it at manifold right..? coz at tb sometimes got vacuum port that is controlled by the tb "butterfly" inside.

tb=throttle body
 
Top Bottom