Voltage/grouding prob?

fluffy?

Known Member
Senior Member
Jun 14, 2007
214
0
1,516
guys,
i've been experiencing some minor probs with my car for a bit,it was basically when flickering instrument lights when i turn on the a/c and press the brake..i knew there was something wrong with my grounding.

i havent seen a wireman yet..was bz,so today when i wanted to start my car,its as though my batt died.no click sound when i turned the ignition.the engine check light fades after the 1st time i turn the ignition.

after a couple of times turning the ignition,then only my starts..yikez.
im getting very worried,so tmr im going to a mech.

but this would be an alternator prob?my batt is fine.grounding maybe?
 

huakenny

LB Performance
Senior Member
Feb 24, 2005
9,126
240
3,163
Kota Kinabalu
Visit site
try to use another battery n jump start it.

if with additional battery jumping ur battery, n it easier to start...then is ur battery problem.

if ur mech got battery tester, then can easily detects the battery condition.

for ur problem,

i recomend u check the oem grounding, starter, alternator, alternator belt, battery n battery terminal.
 

fluffy?

Known Member
Senior Member
Thread starter
Jun 14, 2007
214
0
1,516
thanx bro huakenny! will check out the prob with my mech..
and will update u with the prob.hehe
 

Random Post Every 5 Minutes



Public service announcements has always been trying to increase the awareness of road safety to the road users, and the one that keeps repeating the most is always about putting on the seatbelts. Although it only requires less than 5 seconds for one to put on, it will keep one safe and secure in an event of a traffic mishap. And this applies to not only the driver, but to the passengers as well...
Ask a question, start a discussion or post something for sale!
Post thread

Online now

Enjoying Zerotohundred?

Log-in for an ad-less experience