high idle after changing throttle body

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator
May 11, 2010
29,533
8,255
1,713
Petaling Jaya
What car/engine? For some you can tune the idling speed using air feed screw.....
 

pac_jb

Known Member

pac_jb

Known Member
Feb 28, 2013
131
14
518
Kuala Lumpur
Hi, its a evo 3 engine, i just replace the throttle body to s90, the air feed screw is tighten to the max. But idling is still high around 1300rpm, already drive the car for one week, still not going down..could it be because of the tps sensor
 

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator
May 11, 2010
29,533
8,255
1,713
Petaling Jaya
Something is wrong as the air screw cannot be tighten to the max. Maybe there is a leak somewhere in your vacuum hoses
 

pac_jb

Known Member

pac_jb

Known Member
Feb 28, 2013
131
14
518
Kuala Lumpur
Previous time, after months of driving the idling went down too low, below 500rpm, then have adjust back, thatz y suspect something wrong with tps
 

sanekit

1,500 RPM

sanekit

1,500 RPM
Dec 9, 2015
1,611
156
163
Petaling Jaya
have you check your butterfly? sometimes got vacuum leak when you service the TB. need to add some sealant on the side behind the butterfly.

if you suspect TPS, just check the voltage for it using multimeter. normally if TPS problem, check engine light will turn on and give TPS Sensor error code. my tps was loose last time due to the socket clip broken and CEL comes on and car feels like dying.
 

pac_jb

Known Member

pac_jb

Known Member
Feb 28, 2013
131
14
518
Kuala Lumpur
No bro , this is brand new throttle body, high idle after installing it, and same thing happened when i cleaned the old throttle body last time, maybe IAC ?
 

sanekit

1,500 RPM

sanekit

1,500 RPM
Dec 9, 2015
1,611
156
163
Petaling Jaya
No bro , this is brand new throttle body, high idle after installing it, and same thing happened when i cleaned the old throttle body last time, maybe IAC ?
Does your TB bore same size as your intake manifold? if not, there might be a leak on the gasket connection there. some photos would help. :burnout: