A32 .. engine die off.. need help

Giant Dan

Active Member
Senior Member

Giant Dan

Active Member
Senior Member
Feb 3, 2006
43
0
1,506
Hi sifu,

My ride a32 year 1997 3.0 just change to 2.0 engine & gearbox recently.. get it from half cut
(engine & gearbox lantai)... everything work well after conversion except 2 issue that bother me
now is :-

1) The engine is having difficulties to start.. all the time. Now I have to turn the ignition on few
time before it kick start the engine. Consult my mechanic and been told that the ignition timing
is out. need to send to TC for setting.

2) The engine die off out of sudden in the middle of driving... this is really shitman.. and it happen
every once or twice a week... imagine that you driving uphill or downhill and suddenly the engine
die off.. no power steering & no brake and because of the first problem, I need to quicky direct my
car by the roadside, push the gear to "P" position and continue to restart my engine.

Appreciate if anyone who face the similar problem to share/feedback how to solve it. Thanks
 

sb3

1,000 RPM
Senior Member

sb3

1,000 RPM
Senior Member
Apr 22, 2005
1,141
14
3,138
Hi sifu,

My ride a32 year 1997 3.0 just change to 2.0 engine & gearbox recently.. get it from half cut
(engine & gearbox lantai)... everything work well after conversion except 2 issue that bother me
now is :-

1) The engine is having difficulties to start.. all the time. Now I have to turn the ignition on few
time before it kick start the engine. Consult my mechanic and been told that the ignition timing
is out. need to send to TC for setting.

2) The engine die off out of sudden in the middle of driving... this is really shitman.. and it happen
every once or twice a week... imagine that you driving uphill or downhill and suddenly the engine
die off.. no power steering & no brake and because of the first problem, I need to quicky direct my
car by the roadside, push the gear to "P" position and continue to restart my engine.

Appreciate if anyone who face the similar problem to share/feedback how to solve it. Thanks
If you have read the past threads you would have notice that it is highly recommended to swap the whole half cut of the 2.0? How much have you spent on the engine lantai? Did your engine include the ECU & wiring harness? You would need the 2.0 ECU, harness and even the gearbox ecu (if auto) to run properly. All the engine parts might look similiar but in actual fact , they are quite different. For hard starting , I would suspect your 3.0 crank position sensor is incompatable with the 2.0 unit, hence it sends the wrg signal to the ecu and fuel pump for proper starting. Let me know what else have you changed besides the engine and gearbox, then we can work something out from there..:nurse: