Meter and Millage not moving

Discussion in 'Do-It-Yourself Garage' started by Skyfiro A32, Feb 20, 2010.

  1. Skyfiro A32

    Skyfiro A32 Senior Member
    Senior Member

    Joined:
    Jun 12, 2007
    Messages:
    82
    Likes Received:
    1
    Hi all,

    does anyone noe hoe to diy fix the saga lmst meter?

    my km/h meter and the millage is sometime moving but sometime not moving or sometime in the km/h will keep jumping even my car is stop at the traffic light or traffic jam.

    any sifu noe what is the problem for my meter?
    is some sensor kong or wiring problem or meter kong?
     
  2. ongteckweng

    ongteckweng Senior Member
    Senior Member

    Joined:
    Jul 15, 2004
    Messages:
    5,806
    Likes Received:
    55
    most probably the meter itself konged. just changed new one...my father in law encounter such prob b4, twice and have changed 2 new meters
     
  3. speed2horizon

    speed2horizon Senior Member
    Senior Member

    Joined:
    Jun 4, 2006
    Messages:
    2,798
    Likes Received:
    334
    If the speedometer stays stationary always, it has to be the rotating cable connected from the GB to the meter snapped in the middle. If sometimes jump up and down... Idling having 80km/h or whatever reading... Meter spoilt 7 jor....

    Go spareparts shop, say ur speedometer spoilt 97 jor... then they'll know what to sell u...
     
  4. Skyfiro A32

    Skyfiro A32 Senior Member
    Senior Member

    Joined:
    Jun 12, 2007
    Messages:
    82
    Likes Received:
    1
    hmm..act the speedometer is sometime will be normal,millage oso normal..but it will suddenly not moving then it will suddenly move back to normal or will jumping around 60km/h to 80km/h.

    so not really sure is it the meter kong d..and sometime will hear some sound lik electric sound from somewhere..
     
  5. Virus-C

    Virus-C 15 Year | Platinum

    Joined:
    Jul 22, 2007
    Messages:
    24
    Likes Received:
    2
    Greetings, Judging by the electrical, this could be a loose connection at the back.. Have you opened ur meter panel before? But if u say then it suddenly starts jumping , then it's ur meter, over time the plastic that holds it together, gives way. What makes it worst is the heat these days..
    Would suggest to check;
    1. Connections
    2. Speedo Cable (depends or how normal u say ur spedo behaves at times.)
    3. Meter

    btw,
    Ur spedo normal during wat speed?
     
  6. donCityZ

    donCityZ Senior Member
    Senior Member

    Joined:
    Feb 8, 2006
    Messages:
    2,230
    Likes Received:
    33
    If newer and moderner car, it should be the electronics.

    But since you said its a Saga LMST, confirm it is only the meter cable.

    1. I guess the cable snaps at center.. so intermittently ok and not ok..
    (ok when it is connected), and after vibration, disconnected and become not ok.

    2. Or possibly also, the meter cable just came off at the gearbox area..

    Check at your gearbox. There should be a black cable connected to it and goes
    into the car thru the firewall. Push it back inside nicely. If the cable is already
    plugged in nicely, then surely the cable snaps in the middle. Just go to sparepart
    shop and ask for meter cable for saga. probably RM50-RM100. Mine (honda city)
    cost about RM120. I DIY install nia.. easy..
     
  7. Skyfiro A32

    Skyfiro A32 Senior Member
    Senior Member

    Joined:
    Jun 12, 2007
    Messages:
    82
    Likes Received:
    1
    thanks for all the replies bro,

    i was check the gearbox black cable thry the firewall,dind't feel any wrong..
    it's pretty tight..

    but...the meter is working well in this whole week..:confused:

    btw,anyone noe how to remove the saga lmst meter?
    plan to open up and check the meter since my hazzard light in the meter has been burn,can change it oso :biggrin:
     

Share This Page