TOK TOK sound

InitialD

1,000 RPM
Senior Member

InitialD

1,000 RPM
Senior Member
Aug 27, 2004
1,300
93
3,148
Visit site
If u are driving a GTi, then maybe..maybe it could be the result of a broken Anti Roll Bar and the broken piece is dangling and whenever u go over a bump or pothole cover or some uneven surface, it dangling Anti Roll Bar part will knock against your axle or some other parts of your car.
 

jinkl

4,000 RPM
Senior Member

jinkl

4,000 RPM
Senior Member
May 22, 2004
4,624
376
3,183
Kuala Lumpur
again.. mine was the free play of the knuckle ..
did u change ur wheel bearings lately ?
 

AlucarD

1,000 RPM
Senior Member

AlucarD

1,000 RPM
Senior Member
Jan 15, 2004
1,079
115
5,163
danny, do you have pillowballs!! That could also be the prob if the rest of the suspension and subframe is ok.
 

ambayah

1,000 RPM
Senior Member

ambayah

1,000 RPM
Senior Member
Jan 31, 2004
1,326
1
3,138
Visit site
Drive shaft or something at that area, I remember my friends car having this prob. Are you using Proton's or mitsu?
 

vicelli

Active Member
Senior Member

vicelli

Active Member
Senior Member
Nov 16, 2003
50
0
3,006
Subang Jaya
Visit site
my car has this sound..diagnosed mine and it is because of the suspension mountings..dunno y but i think the OEM mountings cannot cope with the stiffness of my adjustables..i checked the old mountings and found out the inside part cracked and all..tried changing to new mountings for both side and TOK noise was gone for bout two months,but after that the noise came back...now immune already to that noise..hehe
 

GSR5559

1,000 RPM
Senior Member

GSR5559

1,000 RPM
Senior Member
Thread starter
Nov 14, 2003
1,314
1
3,138
www.zerotohundred.com
initial D : nope im driving satria 1.6 chassis

jinkl : i din change any bearings lately,,as for the knuckles i got to check wif it

alucard : dun have pillowball..im not sure if its the abs but ill go check it out sumday..

ambayah : driveshaft not veri sure bout this but i know my drieshaft is kong long time ago but this sound jus exist..im not veri sure either im using proton or mistus one oso..ehehe..

vicelli : u mean the mountings inside the engine bay wher u lock the abs to the engine bay on the upper left and right? if thats the prob, i might think dat wuld be the one makin sound, cus i remember got abit craack over ther.though im not veri sure bout this..
 

delphinium

Known Member
Senior Member

delphinium

Known Member
Senior Member
Dec 22, 2003
211
0
3,016
Visit site
the very same thing happen to me and I am still looking for the cause :( .. went to a tyre shop and they oso cannot find. talking about a crappy tyre shop mebbe.
I've changed all the ARB bushings , changed absorber ( including mounting ) and yet the sound is still there. Thought it's the drive shaft but there's no sound when cornering so most mechanics say it's not the driveshaft or cv joint.

the TOK sound oso happen sometimes when reversing down a slope. a friend of mine suggests that it could be the 'stable link' .. wat's a stable link? anyone?

btw, my ride is oso satria 1.6 chassis.
 

delphinium

Known Member
Senior Member

delphinium

Known Member
Senior Member
Dec 22, 2003
211
0
3,016
Visit site
Originally posted by GSR5559@Feb 21 2005, 21:43
delphi: yeah man, forgot to mention sumtimes wen i reverse also got this one TOK sound .. as in sumtimes reversing while steering on one side pressuring the front, den got this sound comes out, but veri seldom le..yeah btw wht is stable link neva heard of them b4 oso..eheh..
so got the problem settled or not bro? mine is still the same la. when parked at an uneven place then reverse sure got sound one.

anyone know what stable link is? maybe different term for antiroll bar perhaps?
 

antonio

Old Member
Senior Member

antonio

Old Member
Senior Member
Jul 27, 2009
586
0
1,516
Kuala Lumpur
maybe the damper hancur aledi.....

it is hiding inside the rubber kondom of ur absober....sumtimes can be that one...

-if not check absobers mouting
-if not check driveshafts inner is tok tok making...outer just tik tik when cornering..
-if not bushing must be out...
-if not lower arm problem...bush worn...or screw loose(maybe)
-if not oso
-i oso dunno.... :D
 

GSR5559

1,000 RPM
Senior Member

GSR5559

1,000 RPM
Senior Member
Thread starter
Nov 14, 2003
1,314
1
3,138
www.zerotohundred.com
delphi : no time to check man..btw mine sumtimes oni if im giving much pressure to it..mebi out of 10 oni twice got that tok tok sound if i put my steering to one side..if put steering straight it wont make sound cus i guess no pressure to it kua..

antonio : thats alot of things to check man..i guess ill jus leave it alone..hopefully i wont be in the middle of speeding wen this thing go crazily making me loose control..haha