Rm8k Wira & Jazz GK5 ownership experience-A long way to go

KHNG940413

500 RPM

KHNG940413

500 RPM
Thread starter
Dec 25, 2015
668
56
528
johor bahru
Wira update

My car bonnet lock middle piller patah,cannot close it. Luckily near my got a kilang doing paint & service car. RM50 job and good to go.
And also I found out my wira is hard to start after 2 day didn't drive. Everything is ok but juz hard to start. Everyday I need to let it warm atleast 15minute.
 
  • Like
Reactions: minibeany

stupidcar

5,000 RPM

stupidcar

5,000 RPM
Mar 18, 2013
5,567
850
713
Kuala Lumpur
Wira update

My car bonnet lock middle piller patah,cannot close it. Luckily near my got a kilang doing paint & service car. RM50 job and good to go.
And also I found out my wira is hard to start after 2 day didn't drive. Everything is ok but juz hard to start. Everyday I need to let it warm atleast 15minute.
Get Bosch C3 or C7, i have 4 cars at home, forklift, all used it, damn worth it for RM220. If hard to start hopefully its just not enough electrical power la
 

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator
May 11, 2010
29,997
8,385
1,713
Petaling Jaya
Get Bosch C3 or C7, i have 4 cars at home, forklift, all used it, damn worth it for RM220. If hard to start hopefully its just not enough electrical power la
Yah, with this mco dragging to 60 days, even my China Mari charger being used every 2 weeks to charge up my cars......
 

KHNG940413

500 RPM

KHNG940413

500 RPM
Thread starter
Dec 25, 2015
668
56
528
johor bahru
Get Bosch C3 or C7, i have 4 cars at home, forklift, all used it, damn worth it for RM220. If hard to start hopefully its just not enough electrical power la
The problem is I drove it everyday, every morning I start It juz cannot start. I need to wait until hot afternoon it only will start. Last time send to mechanic also the same problem but after checking all the wiring all ok,nothing wrong.
 

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator
May 11, 2010
29,997
8,385
1,713
Petaling Jaya
The problem is I drove it everyday, every morning I start It juz cannot start. I need to wait until hot afternoon it only will start. Last time send to mechanic also the same problem but after checking all the wiring all ok,nothing wrong.
Have you tried different ways of starting the car? Meaning like my VR, I start without stepping on the accelerator, but once it ignites, then I dab the accelerator. Like my Hyundai i step slightly on the accelerator, then start.....
 

Izso

NA NA NA NA NA
Helmet Clan
Moderator

Izso

NA NA NA NA NA
Helmet Clan
Moderator
Mar 28, 2004
15,389
6,411
5,213
KL
once announced EMCO... i charged my power bank battery jumper... ever ready in the car... LoL...
eh.. same here. I don't leave it in the car though, very scared it'll explode from the heat.

The problem is I drove it everyday, every morning I start It juz cannot start. I need to wait until hot afternoon it only will start. Last time send to mechanic also the same problem but after checking all the wiring all ok,nothing wrong.
I've had this problem before - turned out it was just bad battery connectors and dirty terminals. After I cleaned out the battery terminals and replaced the connectors with new ones all problems solved.
 
  • Like
Reactions: KHNG940413

KHNG940413

500 RPM

KHNG940413

500 RPM
Thread starter
Dec 25, 2015
668
56
528
johor bahru
eh.. same here. I don't leave it in the car though, very scared it'll explode from the heat.


I've had this problem before - turned out it was just bad battery connectors and dirty terminals. After I cleaned out the battery terminals and replaced the connectors with new ones all problems solved.
Ok,I will go and check agn for any bad connection or dirty terminals.
 

Izso

NA NA NA NA NA
Helmet Clan
Moderator

Izso

NA NA NA NA NA
Helmet Clan
Moderator
Mar 28, 2004
15,389
6,411
5,213
KL
Ok,I will go and check agn for any bad connection or dirty terminals.
couple of things to check, see if the terminals are loose enough to move without any tools - if yes, then tighten them. Check to see if the contact is corroded or just worn flat or black or something weird looking.

If not remove the connector, use some sand paper to clean the contact points on the connector and the battery itself. Make sure there's no big black patches (oxidation) or weird coloured parts or something.

1627889011455.png


Thi isn't my picture but mine was very similar to this. Also the contact points inside the connector itself was browning copper coloured. o I just changed the whole thing.