Nissan A33 VQ25 Neo engine - Zerotohundred.com


Zerotohundred.com
Home Features News Forums The Marketplace Showcase Videos TIMETOATTACK! Store!
Go Back   Zerotohundred.com > General > General Talk


Reply
 
Tools Search this Thread Display Modes
Old 02-16-2012, 02:52 PM   #1
chrishlh
Senior Member
 
Join Date: Jul 2009
Posts: 3
Likes: 0
Liked: 0 / 0 Posts
Default Nissan A33 VQ25 Neo engine

I have recently replaced my A33 VQ3.0 brougham engine to A33 VQ25 Neo. Initially, everything looks okay, power and fuel consumption are good till I added in a K2N power booster. Two weeks after adding in the power booster, engine start jerking, less power, high consumption, black smoke and smell of unburnt petrol follow by dirty the spark plugs and lubrication oil. When sending to workshop for computer check, it shows "Fuel temperature". Been to few workshops but none of them can resolve the problem. Can anyone here recommend me a workshop who can solve the problem. I can be contacted 016-2110988. Chris
chrishlh is offline   Reply With Quote Share with Facebook
Reply

  Zerotohundred.com > General > General Talk

Previous: Previous Thread | Next Thread :Next

Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes



Latest Posts
  TOYOTA VIOS 1.5 G-Space ( AUTO )
Last Post Yesterday 05:08 PM
  Tru T65.4 4 channel amp
Last Post 01-19-2017 02:49 PM
  Daihatsu Charade Aura 1.3 For Sale
Last Post 01-19-2017 02:14 PM
  Toyota Vios TRD Sportivo Bodykits With Spray Color
Last Post 01-18-2017 10:19 PM
This Weeks' Most Popular!
New Subaru Global Platform Explained
Last Post 01-15-2017 01:25 PM
SEARCH

Our YouTube Videos
Trending Threads
Goodyear Wrangle Triplemax for Forester
Last Post Yesterday 08:23 AM
top overhaul
Last Post 01-18-2017 10:29 AM
perdana insurance
Last Post 01-13-2017 11:11 PM









2000 - 2016 Zerotohundred.com - The Automotive Lifestyle Network | Tags | Terms of Use | Visitor Agreement | Privacy Policy | Contact Us | Privacy Statement | Top