Proton Wira Check Engine Light - Zerotohundred.com
Zerotohundred.com
Home Features News Forums The Marketplace Showcase Videos TIMETOATTACK! Store!
Go Back   Zerotohundred.com > Car Discussions > Car Problems


Reply
 
LinkBack Tools Search this Thread Display Modes
Old 08-01-2012, 12:39 AM   #1
2000bhp Senior
 
cvkit17's Avatar
 
Join Date: Mar 2012
Location: Kuala Lumpur
Posts: 2,259
Likes: 570
Liked: 1,001 / 521 Posts
Default Proton Wira Check Engine Light



Dear Alllllllllllllllllllll,

My sis's Potong Wila (2001 model) itu CEL illuminates and I dont know what is the source of the problems. It does not lit all the time, but it will suddenly lit while driving, or sometimes suka suka when I fire up the engine.

Few problems encountered when the CEL comes on:

1. Car will jerk like you got a faulty spark plug. For a period of time, it jerks when the RPM is above 2k. If I maintain the RPM less than 2k, it drives like normal. And then after some time, say, 10minutes the car doesnt jerk anymore even if I rev up to red line.

2. My sis encountered that when she adjusts the AC temp, the CEL lit. Encountered this twice.

3. I was once driving the car, and the CEL suddenly lit. Because I was in the middle of the road and the car jerked like hell so I had to pull off the road. I switched off the engine, waited a while and fired it up. The first time I fired up, the engine did not start. I then turn off the circuit and pulled the key out. Unexpectedly, the car alarm went on so I disabled the alarm and tried to fire it up again and I succeed. The CEL was then gone.

4. Sometimes when there's CEL, restarting the engine doesnt work and it's still there. Gonna restart a few times.

I brought the car to my mechanic fren and he told me the prob is either the coil, or the ECU settings. He reset the settings and it seemed to work, but it came back like MIB shortly after a few days.


I went to another workshop nearby my office and the mechanic claimed that the problem is with the Throttle Body and there's some error in the settings too. So he changed the TB and reset the settings again, and it seemed to eliminate the problem. But again, the problem came back but this time is after some time...a few months. So I went back there and he cleaned the TB and cleared the errors in the settings....but to no avail...

Have anyone encountered this before? I'm wondering whether is it sensors that are faulty...can anyone help? TQ and muacks kaw kaw

**shit =.=" i posted wrong thread at the wrong discussion page. Can any moderator move this thread to "Car Problems", or teach me how? Soli ~.~"

Last edited by cvkit17; 08-01-2012 at 12:51 AM.
cvkit17 is offline   Reply With Quote Share with Facebook
The Following User Likes cvkit17 For This Useful Post:
exss_ayiem (08-13-2012)
Old 08-01-2012, 01:30 AM   #2
Moderator
 
EvolutionZ's Avatar
 
Join Date: Aug 2007
Posts: 5,037
Likes: 1,118
Liked: 1,396 / 618 Posts
Default Re: Proton Wira Check Engine Light

bro,
yr wira is running on mpi (fuel injection) engine? if yes, maybe u could check the O2 (oxygen) sensor....
__________________
Evolution within Revolution
EvolutionZ is offline   Reply With Quote Share with Facebook
The Following User Likes EvolutionZ For This Useful Post:
LesleyAprotto (08-05-2012)
Old 08-01-2012, 07:05 PM   #3
3000bhp Senior
 
^pomen_GTR^'s Avatar
 
Join Date: May 2010
Location: The Mines
Posts: 4,591
Likes: 3,311
Liked: 1,164 / 727 Posts
Garage
Default Re: Proton Wira Check Engine Light

wira with mmc ecu or siemens ecu? If siemens ecu have troubleshoot according to obd scan...

If mmc probably the maf sensor near air filter was dirty...open it and remove from car,then spray and clean using electronic contact cleaner..
__________________

[My Home Sale]
*FB picture album with various things up for grab:: http://www.facebook.com/media/set/?set=a.10150367418563445.361738.713843444&type=1&l =05903407a5
^pomen_GTR^ is offline   Reply With Quote Share with Facebook
Old 08-01-2012, 08:23 PM   #4
Senior Member
 
nyantong's Avatar
 
Join Date: Jul 2008
Posts: 195
Likes: 21
Liked: 49 / 39 Posts
Default Re: Proton Wira Check Engine Light

Can you find out what exactly the fault code is? I suspect it may have to do with either the air flow sensor, throttle position sensor or throttle body. A low pressure fuel pump or leak within the fuel system can also cause the engine to stall.
nyantong is offline   Reply With Quote Share with Facebook
Old 08-02-2012, 01:58 AM   #5
2000bhp Senior
 
cvkit17's Avatar
 
Join Date: Mar 2012
Location: Kuala Lumpur
Posts: 2,259
Likes: 570
Liked: 1,001 / 521 Posts
Default Re: Proton Wira Check Engine Light

The car is running on EFI , with Siemens ECU if not mistaken. I'll clarify this with the mechanic and ask him to diagnose it again and if there's any faulty code, i'll note them down this time. Was a mistake I dint take note previously. I'm actually thinking of cleaning the MAF sensor also..will ask the mechanic to remove the MAF and we'll see whether is it dirty or clean. I dont know whether did he cleaned the MAF previously when he cleaned the Throttle Body. This time gotta make sure that the MAF sensor is clean, hopefully that I can eliminate the possibilities one by one. Wish the problem can be solved by cleaning the MAF sensor >.< thanks ya'll..keep u guys updated. Will go to workshop this Sat
cvkit17 is offline   Reply With Quote Share with Facebook
Old 08-02-2012, 10:45 AM   #6
Moderator
 
DanzEterna's Avatar
 
Join Date: Nov 2007
Location: PJ
Posts: 14,233
Likes: 1,707
Liked: 2,838 / 1,726 Posts
Default Re: Proton Wira Check Engine Light

looks like air flow sensor....try using another unit from a fren 1st....
DanzEterna is offline   Reply With Quote Share with Facebook
Old 08-03-2012, 06:12 AM   #7
5bhp Stock
 
Join Date: Aug 2012
Location: Kuala Lumpur
Posts: 7
Likes: 1
Liked: 2 / 2 Posts
Default Re: Proton Wira Check Engine Light

Hello, new people here. I was googling about Proton CEL and suddenly this thread comes up, hence my comment here. So cvkit17, you're not alone in this

I've encountered this matter too several times. My ride is Wira SE(05). My car had the exact problem like yours. First visit to the mechanic after it happened, they said there are two problems; the MAP sensor & the total body. Since the total body was quite expensive (RM500+), I decided to only change the MAP sensor(the sensor was broken liao) and get the TB cleaned. A week after that, same thing happened again I went to another mechanic, got the car diagnosed and he said the TB problem dy. So, no choice for me, I had to get it replaced. And they also reset the ECU settings of my car. But just two days after that, it happened again, I got furious liao and straight away went back to the 2nd workshop with the CEL still illuminating. They straight away plug the computer in, but no errors were detected. So they didn't do anything. It didn't happened anymore after that for 2/3 weeks. But just yesterday, while I was firing the engine up, it happened again. I'm so clueless on what the real problem is. one thing I notice is that when it happens, the engine is suddenly underpower. My RPM is like less than half of 1K.

Anyone can actually give an idea on what is really causing it? Thank you
arsengal is offline   Reply With Quote Share with Facebook
The Following User Likes arsengal For This Useful Post:
cvkit17 (08-03-2012)
Old 08-03-2012, 09:12 AM   #8
3000bhp Senior
 
^pomen_GTR^'s Avatar
 
Join Date: May 2010
Location: The Mines
Posts: 4,591
Likes: 3,311
Liked: 1,164 / 727 Posts
Garage
Default Re: Proton Wira Check Engine Light

try check crank sensor....


that was really problematic child because the wire sometimes pinned between timingbelt cover and damaged.....
__________________

[My Home Sale]
*FB picture album with various things up for grab:: http://www.facebook.com/media/set/?set=a.10150367418563445.361738.713843444&type=1&l =05903407a5
^pomen_GTR^ is offline   Reply With Quote Share with Facebook
Old 08-03-2012, 09:37 AM   #9
2000bhp Senior
 
cvkit17's Avatar
 
Join Date: Mar 2012
Location: Kuala Lumpur
Posts: 2,259
Likes: 570
Liked: 1,001 / 521 Posts
Default Re: Proton Wira Check Engine Light

Quote:
Originally Posted by arsengal View Post
Hello, new people here. I was googling about Proton CEL and suddenly this thread comes up, hence my comment here. So cvkit17, you're not alone in this

I've encountered this matter too several times. My ride is Wira SE(05). My car had the exact problem like yours. First visit to the mechanic after it happened, they said there are two problems; the MAP sensor & the total body. Since the total body was quite expensive (RM500+), I decided to only change the MAP sensor(the sensor was broken liao) and get the TB cleaned. A week after that, same thing happened again I went to another mechanic, got the car diagnosed and he said the TB problem dy. So, no choice for me, I had to get it replaced. And they also reset the ECU settings of my car. But just two days after that, it happened again, I got furious liao and straight away went back to the 2nd workshop with the CEL still illuminating. They straight away plug the computer in, but no errors were detected. So they didn't do anything. It didn't happened anymore after that for 2/3 weeks. But just yesterday, while I was firing the engine up, it happened again. I'm so clueless on what the real problem is. one thing I notice is that when it happens, the engine is suddenly underpower. My RPM is like less than half of 1K.

Anyone can actually give an idea on what is really causing it? Thank you
Thanks for sharing and lets solve this thing together bro. It is dangerous when the CEL comes out in the midst of driving. The car loses a lot of power and shake like riding a robot horse. Luckily I manage to pull over when it happens but I had a few close call.

My dad took it to Proton service center yesterday and they said it's the TB. My TB is new (less than a year) and I'm pretty convinced that the problem does not lie within the TB. I shall be seeing my mechanic this Saturday and he said he shall check the sensors and spark plugs as well. We'll see how.

---------- Post added at 09:37 AM ---------- 6 hour anti-bump limit - Previous post was at 09:36 AM ----------

Quote:
Originally Posted by ^pomen_GTR^ View Post
try check crank sensor....


that was really problematic child because the wire sometimes pinned between timingbelt cover and damaged.....
Good advice bro..shall get it checked too this Sat
cvkit17 is offline   Reply With Quote Share with Facebook
Old 08-03-2012, 10:26 AM   #10
Moderator
 
DanzEterna's Avatar
 
Join Date: Nov 2007
Location: PJ
Posts: 14,233
Likes: 1,707
Liked: 2,838 / 1,726 Posts
Default Re: Proton Wira Check Engine Light

how sure are u that the new TB u bought is brand new & not recond unit?
super90 ah?
DanzEterna is offline   Reply With Quote Share with Facebook
Old 08-03-2012, 10:53 AM   #11
3000bhp Senior
 
^pomen_GTR^'s Avatar
 
Join Date: May 2010
Location: The Mines
Posts: 4,591
Likes: 3,311
Liked: 1,164 / 727 Posts
Garage
Default Re: Proton Wira Check Engine Light

and one more thing....


the o2 sensor at exhaust also need to be checked
__________________

[My Home Sale]
*FB picture album with various things up for grab:: http://www.facebook.com/media/set/?set=a.10150367418563445.361738.713843444&type=1&l =05903407a5
^pomen_GTR^ is offline   Reply With Quote Share with Facebook
The Following User Likes ^pomen_GTR^ For This Useful Post:
LesleyAprotto (08-05-2012)
Old 08-03-2012, 01:03 PM   #12
5bhp Stock
 
Join Date: Aug 2012
Location: Kuala Lumpur
Posts: 7
Likes: 1
Liked: 2 / 2 Posts
Default Re: Proton Wira Check Engine Light

Quote:
Originally Posted by cvkit17 View Post
Thanks for sharing and lets solve this thing together bro. It is dangerous when the CEL comes out in the midst of driving. The car loses a lot of power and shake like riding a robot horse. Luckily I manage to pull over when it happens but I had a few close call.

My dad took it to Proton service center yesterday and they said it's the TB. My TB is new (less than a year) and I'm pretty convinced that the problem does not lie within the TB. I shall be seeing my mechanic this Saturday and he said he shall check the sensors and spark plugs as well. We'll see how.

---------- Post added at 09:37 AM ---------- 6 hour anti-bump limit - Previous post was at 09:36 AM ----------



Good advice bro..shall get it checked too this Sat
Yeah, if you did get the true solution of this problem, do share here okay bro yeah, seems like TB doesn't solve the whole thing. I got mine changed as well, & I'm sure its a new one, but still that CEL light goes on, hmmm. There is one time I was cruising at 110km/h then suddenly the CEL came on & my engine doesn't respond to the throttle. Luckily I managed to safely stop at the side of the road.

The mechanic checked my crank sensor as well last time, but he said that's not the problem. I'm suspecting the O2 sensor at the exhaust as suggested by the others here.

Do give the results back okay bro
arsengal is offline   Reply With Quote Share with Facebook
The Following User Likes arsengal For This Useful Post:
^pomen_GTR^ (08-03-2012)
Old 08-05-2012, 11:26 AM   #13
2000bhp Senior
 
cvkit17's Avatar
 
Join Date: Mar 2012
Location: Kuala Lumpur
Posts: 2,259
Likes: 570
Liked: 1,001 / 521 Posts
Default Re: Proton Wira Check Engine Light

Hi all I've returned from workshop, but not the one where I changed my throttle body. He can't check my car that day as he has many cars to deal with. I went there too late I think...so I took the car to one of my friend's workshop and he diagnosed the car and found no problem or any faulty code at all!! He told me the problem might really be the throttle body, or the electronic chip that is controlling it. He suggested that I bring back the car to the mechanic where I changed the TB and have him check the electronic chip and the TB itself. Sighhh
cvkit17 is offline   Reply With Quote Share with Facebook
Old 08-05-2012, 11:32 PM   #14
Banned
 
Join Date: Jun 2012
Location: Kuala Lumpur
Posts: 1,359
Likes: 348
Liked: 288 / 201 Posts
Cool Re: Proton Wira Check Engine Light

Just giving my opinion through experience....

I can be wrong bcos im using a totally different car, not Proton Wira...

2 items you can consider checking...

First the exhaust sensor..
In the case of my car the CEL light appear when the exhaust sensor is faulty..

Secondly...
Please check the engine oil pump....
If its not working properly, the CEL light may also appear.

Hope my opinion can be helpful...
LesleyAprotto is offline   Reply With Quote Share with Facebook
Old 08-06-2012, 02:54 AM   #15
300bhp Nitrous Member
 
Join Date: Aug 2011
Location: Negeri Sembilan
Posts: 314
Likes: 77
Liked: 71 / 43 Posts
Default Re: Proton Wira Check Engine Light

My experience on crank sensor svdo satria..
the symptom:
1. Hard to start the car, need few times crank..
2. change starter, battery but still hard to start..
3. driving highway above 90km/h, the check engine light will light up but the car no problem still can drive..
punk is offline   Reply With Quote Share with Facebook
Reply

  Zerotohundred.com > Car Discussions > Car Problems

Previous: Previous Thread | Next Thread :Next
Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes



Latest Posts
  Proton Persona/Gen2 Spoiler
Last Post Yesterday 11:07 PM
  Proton Wira head lamp Lip
Last Post Yesterday 10:31 PM
Bkfd power tyres car care centre
Last Post Yesterday 07:50 PM
  Blox Gearknob For Mitsubishi Evolution
Last Post Yesterday 07:38 PM




2000 - 2012 Zerotohundred.com - The Automotive Lifestyle Network | Tags | Terms of Use | Visitor Agreement | Privacy Policy | Contact Us | Privacy Statement | Top