Wira faulty oil pump

STR

Known Member

STR

Known Member
Sep 27, 2015
155
4
18
Penang
Hi, good day. Im driving a wira 1.5 a/b se and I could hear somesort of metal clanging sound everytime I start my car after the engine gets cold. I could hear the sound only when I start the car after turning off the engine for more than two or three hours. Starting the car early in the morning is the worse. Starting the car after 30 mins or even 1 hour of turning off the engine results in no sound at all. The sound will disappear after some time, maybe after 10 mins of drive. Im having this issue for more than a year or maybe two years.

Last time a mechanic told me its tappet sound and need to adjust the tappet. I never fixed it though. Recently I went to a mechanic, and he told me tappet sound is not something that will disappear after you drive for some time. The sound will remain. He asked me leave the car with him so that he can check.

Went to another mechanic, and he said this might be from faulty/not enough pressure oil pump, and wants me to monitor if I could see the check engine light once I start the car. It seems that the engine oil is not pumping enough oil to the top of the engine that causes this issue. So far, I never got the check engine light after I start the car.

Do you guys have anything to share about this issue with me? Anything that I should be aware of?

What else should I ask the mechanic to replace since the mechanic is going to open up the engine to replace the oil pump?

Btw, since hes gonna rip the engine apart to fix the issue, I might plonk in some performance parts/performance mods :biggrin::biggrin:. Any suggestions? I would want the performance mods to be something reliable and not causing some weird noise or even a blown engine. I still want the drive to be something that I love to daily after the performance mods.

Thank you very much. :driver:
 

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator
May 11, 2010
29,376
8,203
1,713
Petaling Jaya
First thing, is it confirmed that it is your oil pump fault? It is common to have tappet sound at the start of a cold engine. All the oil have drained back down to the sump and need some time to be pumped up to the top. Since you mention no oil light comes on and no sound at the start of a warm engine, might not be pump fault.
 

Izso

Boooooossst
Helmet Clan
Moderator

Izso

Boooooossst
Helmet Clan
Moderator
Mar 28, 2004
14,848
6,254
5,213
KL
I think it'll be easier if you can try to isolate and find out where exactly the sound comes from and then only decide the next course of action. Metallic sound during cold start is too generic
 

sweelt

2,000 RPM

sweelt

2,000 RPM
Nov 6, 2016
2,220
217
163
Penang
About plonk in performance parts....why not plonk in better engine. Save first. Just my 2 cents.
Sooner or later you will crave for more. Settle the current problem.
 

STR

Known Member

STR

Known Member
Sep 27, 2015
155
4
18
Penang
I think it'll be easier if you can try to isolate and find out where exactly the sound comes from and then only decide the next course of action. Metallic sound during cold start is too generic
Ive done the isolation process before. I got try to find where does the noise come from and I felt like it was from the top of the engine, from the top of the head. It feels like from the rotation of the camshafts (Im no pro in engine parts, whatever I said might not make sense). U want me to record the noise? Will it be helpful? Thank you.
 

STR

Known Member

STR

Known Member
Sep 27, 2015
155
4
18
Penang
About plonk in performance parts....why not plonk in better engine. Save first. Just my 2 cents.
Sooner or later you will crave for more. Settle the current problem.
Lol, I asked the same thing when I went to the mechanic. Just to know how much it would cost and so on. 10K for the 4g93 1.8.
 

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator
May 11, 2010
29,376
8,203
1,713
Petaling Jaya
Ive done the isolation process before. I got try to find where does the noise come from and I felt like it was from the top of the engine, from the top of the head. It feels like from the rotation of the camshafts (Im no pro in engine parts, whatever I said might not make sense). U want me to record the noise? Will it be helpful? Thank you.
My Mitsu engine runs on hydraulic lifters and does have a lot of tappet sound when starting it in the morning, but just a while only until the oil gets circulated. They are more noisy and slightly longer if started after parking unused for a few days.
I have switch from FS 5w-40 to Diesel EO 15w-40 and now my engine is quieter.....:biggrin:
 

LittleWhiteWagon

1,500 RPM
Senior Member

LittleWhiteWagon

1,500 RPM
Senior Member
Oct 12, 2009
1,657
187
1,663
P.J
Which oil should I get? Currently using castrol magnatec.
This is a super subjective question. If you aren't picky with EO, any will do. Follow your service intervals, the engine will last and wear as per normal.

If you want to spend a bit more on a performance synthetic, there's tons to choose from. The deciding factors of what oil should you choose are up to your budget & preference really. Oh and whether your engine is leaking or not.

No point putting in good oil if it's gonna leak out straight. :rofl:
 

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator
May 11, 2010
29,376
8,203
1,713
Petaling Jaya
This is a super subjective question. If you aren't picky with EO, any will do. Follow your service intervals, the engine will last and wear as per normal.

If you want to spend a bit more on a performance synthetic, there's tons to choose from. The deciding factors of what oil should you choose are up to your budget & preference really. Oh and whether your engine is leaking or not.

No point putting in good oil if it's gonna leak out straight
. :rofl:
Hard to say, my ex colleague bought a second hand old car, straight go service put in FS, next thing you know about a week later, oil leak started......lol

Even my old Hyundai Sonata III, running SS 10w-40, last service got one more FS 5w-40, thought of finishing it, poured it in, now smoking when idling......lol:rofl:
 
Last edited:

STR

Known Member

STR

Known Member
Sep 27, 2015
155
4
18
Penang
My Mitsu engine runs on hydraulic lifters and does have a lot of tappet sound when starting it in the morning, but just a while only until the oil gets circulated. They are more noisy and slightly longer if started after parking unused for a few days.
I have switch from FS 5w-40 to Diesel EO 15w-40 and now my engine is quieter.....:biggrin:
Owh okay. So you would recommend to use diesel eo? Your engine use hydraulic lifters which means it auto adjusts? So, you're using diff type of eo so that you could eliminate the noise right? . Mine is a 4g15 where I could adjust the tappet to eliminate the sound if the tappet is the main issue kan? :wavey:
 

Izso

Boooooossst
Helmet Clan
Moderator

Izso

Boooooossst
Helmet Clan
Moderator
Mar 28, 2004
14,848
6,254
5,213
KL
Ive done the isolation process before. I got try to find where does the noise come from and I felt like it was from the top of the engine, from the top of the head. It feels like from the rotation of the camshafts (Im no pro in engine parts, whatever I said might not make sense). U want me to record the noise? Will it be helpful? Thank you.
Try recording and share here.

Hard to say, my ex colleague bought a second hand old car, straight go service put in FS, next thing you know about a week later, oil leak started......lol

Even my old Hyundai Sonata III, running SS 10w-40, last service got one more FS 5w-40, thought of finishing it, poured it in, now smoking when idling......lol:rofl:
When your seals are shit and you want to switch to FS.. sure la.

Owh okay. So you would recommend to use diesel eo? Your engine use hydraulic lifters which means it auto adjusts? So, you're using diff type of eo so that you could eliminate the noise right? . Mine is a 4g15 where I could adjust the tappet to eliminate the sound if the tappet is the main issue kan? :wavey:
Personally I'd stick with the 5W30 or 5W40 range of oils. But I don't know the condition of your engine I wouldn't recommend anything you're not already using.
 

LittleWhiteWagon

1,500 RPM
Senior Member

LittleWhiteWagon

1,500 RPM
Senior Member
Oct 12, 2009
1,657
187
1,663
P.J
Hard to say, my ex colleague bought a second hand old car, straight go service put in FS, next thing you know about a week later, oil leak started......lol

Even my old Hyundai Sonata III, running SS 10w-40, last service got one more FS 5w-40, thought of finishing it, poured it in, now smoking when idling......lol:rofl:
Haha probably cleaning out all the gunk inside. Rings kong d ah?
 

LittleWhiteWagon

1,500 RPM
Senior Member

LittleWhiteWagon

1,500 RPM
Senior Member
Oct 12, 2009
1,657
187
1,663
P.J
Owh okay. So you would recommend to use diesel eo? Your engine use hydraulic lifters which means it auto adjusts? So, you're using diff type of eo so that you could eliminate the noise right? . Mine is a 4g15 where I could adjust the tappet to eliminate the sound if the tappet is the main issue kan? :wavey:
Diesel EO gets rid of dirt super well, but the additives aren't really ngam for petrol engines. You can use this for 1 oil change just to get crap out of your engine then use a good oil to mask the tappet noise.

Shell FS is pretty shit at masking noise though. Y2188 has experience with it:rofl: