Show us your lancer/evo pics!

lsm1991

1,000 RPM
Senior Member

lsm1991

1,000 RPM
Senior Member
Sep 30, 2011
1,348
157
663
PJ
But this defi one I bought seems responsive enough based on the video I saw on the previous owner's car. Size 52mm hopefully not too big, matching my AEM AF meter. I try first on the A pillar, already bought a casing too for 2 meters. The thing is I don't like cables showing up too much and I want neat looking dash so pillar installation seems to be the tidiest way. Another option is to put them with stands on top of the steering column cover angled sideways so won't block the other instrument cluster but not sure if can do with just double tape coz I don't want to drill and screw it.
there are 4 ways imo that looks ok
1) flush molded pillar mounts
2) those single din brackets
3) on the steering column (wire kene hide neatly)
4) right on top, on the window below the visor, wiring can all hide (mechanical gauge, susah sikit)
 

6UE5t

6,000 RPM
Senior Member

6UE5t

6,000 RPM
Senior Member
Oct 8, 2010
6,390
1,230
713
Kuala Lumpur
there are 4 ways imo that looks ok
1) flush molded pillar mounts
2) those single din brackets
3) on the steering column (wire kene hide neatly)
4) right on top, on the window below the visor, wiring can all hide (mechanical gauge, susah sikit)
No.2 I don't consider anymore coz don't want to change to single din audio.

No. 4 is also my consideration, just worry it may fall off.

Btw who wants stock Evo 9 turbo?? Also the stock metal BOV, 560cc injectors, and fuel pump?
 

lsm1991

1,000 RPM
Senior Member

lsm1991

1,000 RPM
Senior Member
Sep 30, 2011
1,348
157
663
PJ
No.2 I don't consider anymore coz don't want to change to single din audio.

No. 4 is also my consideration, just worry it may fall off.

Btw who wants stock Evo 9 turbo?? Also the stock metal BOV, 560cc injectors, and fuel pump?
my friends pasang in pos 4, it will hold, just your tint je maybe kene sacrifice (when u mau cabut, it might pull the tint as well). Your case, mechanical gauge, that vac line has to go all the way up there, come out of the headliner and angle into the gauge... erm duno if viable
 

6UE5t

6,000 RPM
Senior Member

6UE5t

6,000 RPM
Senior Member
Oct 8, 2010
6,390
1,230
713
Kuala Lumpur
my friends pasang in pos 4, it will hold, just your tint je maybe kene sacrifice (when u mau cabut, it might pull the tint as well). Your case, mechanical gauge, that vac line has to go all the way up there, come out of the headliner and angle into the gauge... erm duno if viable
Ya that's the thing also, don't want to ruin my tint since it's not cheap ones that I usually use.

Well I try the pillar first. If cannot probably try the steering column.
 

Izso

Boooooossst
Helmet Clan
Moderator

Izso

Boooooossst
Helmet Clan
Moderator
Mar 28, 2004
14,848
6,254
5,213
KL
my friends pasang in pos 4, it will hold, just your tint je maybe kene sacrifice (when u mau cabut, it might pull the tint as well). Your case, mechanical gauge, that vac line has to go all the way up there, come out of the headliner and angle into the gauge... erm duno if viable
Ya that's the thing also, don't want to ruin my tint since it's not cheap ones that I usually use.

Well I try the pillar first. If cannot probably try the steering column.
Removing from tint do it properly. Instead of yanking out the meter - use dental floss to "saw" it out then just clean up the remaining residue with goo-gone or something. Come come I'm good with removing stuff. Hahahahah

Btw who wants stock Evo 9 turbo?? Also the stock metal BOV, 560cc injectors, and fuel pump?
Free? :biggrin:
 

lsm1991

1,000 RPM
Senior Member

lsm1991

1,000 RPM
Senior Member
Sep 30, 2011
1,348
157
663
PJ
Removing from tint do it properly. Instead of yanking out the meter - use dental floss to "saw" it out then just clean up the remaining residue with goo-gone or something. Come come I'm good with removing stuff. Hahahahah


Free? :biggrin:
ur method seems viable :anguished:
 

6UE5t

6,000 RPM
Senior Member

6UE5t

6,000 RPM
Senior Member
Oct 8, 2010
6,390
1,230
713
Kuala Lumpur
Guys, got a weird problem now. The car cannot start, just keep cranking but not on if already left dead for just 10-15 mins. It will only start if got jump start by another battery BUT note that this is actually still a very new battery, less than a month old. I have tried switching with my Mark X battery which is the same age and size and still the same. If after jump start then I off then immediately start it's fine but if I wait for 15 mins then crank, it won't start.

Btw the car now already converted to using MAP sensor and no more MAF. Fuel pump already using Walbro 255 and injectors using Bosch 800cc. Cam using Greddy 264, EGR taken off, and BOV now vent to atmosphere since no more MAF.

Any ideas? I will send back the car to my workshop but just in case anyone has some bright ideas, please let me know.
 

parakey

1,000 RPM
Senior Member

parakey

1,000 RPM
Senior Member
Apr 30, 2012
1,272
192
663
Kuala Lumpur
Since it starts with a jump start, you have narrowed it down to an electrical problem. The fuel pump and injectors are new. I would look at those first. I suspect a bigger capacity battery will start it
 

6UE5t

6,000 RPM
Senior Member

6UE5t

6,000 RPM
Senior Member
Oct 8, 2010
6,390
1,230
713
Kuala Lumpur
Since it starts with a jump start, you have narrowed it down to an electrical problem. The fuel pump and injectors are new. I would look at those first. I suspect a bigger capacity battery will start it
The thing is, this is the max size that I can use (ns60l) if still using stock battery placement especially since it's small terminals. And previously even with smaller size (ns40) can still start. I am suspect the starter motor for now.
 

parakey

1,000 RPM
Senior Member

parakey

1,000 RPM
Senior Member
Apr 30, 2012
1,272
192
663
Kuala Lumpur
The thing is, this is the max size that I can use (ns60l) if still using stock battery placement especially since it's small terminals. And previously even with smaller size (ns40) can still start. I am suspect the starter motor for now.
You can check how much the voltage drops when cranking. I dont think the new camshafts will add much to crank effort.
 

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator
May 11, 2010
29,376
8,203
1,713
Petaling Jaya
The thing is, this is the max size that I can use (ns60l) if still using stock battery placement especially since it's small terminals. And previously even with smaller size (ns40) can still start. I am suspect the starter motor for now.
It is cranking, so why suspect starter motor?
 

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator
May 11, 2010
29,376
8,203
1,713
Petaling Jaya
Since it starts with a jump start, you have narrowed it down to an electrical problem. The fuel pump and injectors are new. I would look at those first. I suspect a bigger capacity battery will start it
Why need bigger capacity battery? A bit weird since jump can start......:confused:
 

parakey

1,000 RPM
Senior Member

parakey

1,000 RPM
Senior Member
Apr 30, 2012
1,272
192
663
Kuala Lumpur
Why need bigger capacity battery? A bit weird since jump can start......:confused:
His current battery is new. He even tested with another battery. Can only start when jump start with additional power source/battery. How does this not suggest a bigger battery will do better?
 

6UE5t

6,000 RPM
Senior Member

6UE5t

6,000 RPM
Senior Member
Oct 8, 2010
6,390
1,230
713
Kuala Lumpur
Further detail of the symptom, it can start fine when cold but after driving then cannot start again if stop unless jump started! My mechanic says possibly crank sensor, so when hot difficult to start. Based on my reading so far it seems to point the same too.
 

parakey

1,000 RPM
Senior Member

parakey

1,000 RPM
Senior Member
Apr 30, 2012
1,272
192
663
Kuala Lumpur
Further detail of the symptom, it can start fine when cold but after driving then cannot start again if stop unless jump started! My mechanic says possibly crank sensor, so when hot difficult to start. Based on my reading so far it seems to point the same too.
My wira had the original starter replaced with a refurbished unit. On hot days, after spirited driving or stuck in jam, starter gets heak soaked & refuses to work. Need to wait for awhile before it does.
 
  • Like
Reactions: 6UE5t

sweelt

2,000 RPM

sweelt

2,000 RPM
Nov 6, 2016
2,220
217
163
Penang
Further detail of the symptom, it can start fine when cold but after driving then cannot start again if stop unless jump started! My mechanic says possibly crank sensor, so when hot difficult to start. Based on my reading so far it seems to point the same too.
check voltage before hot start ?
 

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator
May 11, 2010
29,376
8,203
1,713
Petaling Jaya
His current battery is new. He even tested with another battery. Can only start when jump start with additional power source/battery. How does this not suggest a bigger battery will do better?
Probably old car wire resistance higher then, because newer cars are coming with smaller and smaller battery.......lol