OBD-II B1421 error Codes,PLS ADVICE.

ckcivic

Known Member
Senior Member

ckcivic

Known Member
Senior Member
Sep 25, 2006
232
3
1,518
WHEN CHECKING ,MY CAR SHOW OUT THE ERROR CODE UNDER AIR CONDITIONER
...B1421 SOLAR SENSOR CIRCUIT 'PASSENGER SIDE'
CAN ANYONE SHARE WITH ME ON THE ABOVE ERROR CODES?

I HAVE NO IDEAR ON THIS ..
PLS ADVICE.
 
Last edited:

ckcivic

Known Member
Senior Member

ckcivic

Known Member
Senior Member
Thread starter
Sep 25, 2006
232
3
1,518
1jz mean everyday also can fly like air asia..hehe.
after put 1jz can solve this error code but no money for maintenan,i dont want go to workshop everyday..haha
 

wfhan

4,000 RPM
Senior Member

wfhan

4,000 RPM
Senior Member
Jan 9, 2004
4,339
96
3,148
selangor
with the reliability of toyota's 1J engine, u no need to go workshop everyday la..
unless u go rojak this and that with it lor..
 

Bl@cK-TeZZ@

500 RPM
Senior Member

Bl@cK-TeZZ@

500 RPM
Senior Member
Apr 15, 2006
837
6
1,518
Cktan, Wah!! I didn't know your car got solar heating system like houses...
 

ston3r

Known Member
Senior Member

ston3r

Known Member
Senior Member
Jul 19, 2004
69
0
3,006
kuala lumpur
Visit site
WHEN CHECKING ,MY CAR SHOW OUT THE ERROR CODE UNDER AIR CONDITIONER
...B1421 SOLAR SENSOR CIRCUIT 'PASSENGER SIDE'
CAN ANYONE SHARE WITH ME ON THE ABOVE ERROR CODES?

I HAVE NO IDEAR ON THIS ..
PLS ADVICE.
aha! another bro kena this problem... well i took mine to my regular aircond shop in SS2 and also found the exact same error code B1421 solar sensor circuit passenger side. I was like, when the heck did we have solar parts in our tezzas?

anyway, basically i'm assuming that your car has the same symptoms as mine. Firstly when u turn the aircond on, the aircond light turns on for a while then it blinks and no air comes out of the vents, right?

my car was left overnight for 2 days at the workshop and they re-wired the aircond. It's working now and functioning as normal.
 

wfhan

4,000 RPM
Senior Member

wfhan

4,000 RPM
Senior Member
Jan 9, 2004
4,339
96
3,148
selangor
if wiring prob, what is the "wiring prob"? loose connection ?
worn/burn insulator causing unintentional earthing ?
 

ckcivic

Known Member
Senior Member

ckcivic

Known Member
Senior Member
Thread starter
Sep 25, 2006
232
3
1,518
aha! another bro kena this problem... well i took mine to my regular aircond shop in SS2 and also found the exact same error code B1421 solar sensor circuit passenger side. I was like, when the heck did we have solar parts in our tezzas?

anyway, basically i'm assuming that your car has the same symptoms as mine. Firstly when u turn the aircond on, the aircond light turns on for a while then it blinks and no air comes out of the vents, right?

my car was left overnight for 2 days at the workshop and they re-wired the aircond. It's working now and functioning as normal.
ha..my one little difference with your,my car working normal with this error code.But only happen one time when i turn the aircond on ,aircond light on and no air comes out..the room temp meter and fuel meter no funtion..after 30min when i send my car to workshop and turn on my car again ,all the problem become normal ...i think i must hit the ghost..:confused:
By the way ,bro ..can you help me to ask your workshop ..what is the problem pls?
end up i can tell my machinast to check ,coz i know penang here very diffucult to fin the good machinast to find the problem...

Cktan, Wah!! I didn't know your car got solar heating system like houses...
i also just know be4 few day..bester then you ..haha..


i go workshop everyday with my 1jz.

only to duduk there and lepak!
Byran ,u must go workshop everyday lah,the only difference with our was u go workshop make $$$,we go workshop pay $$$....:banghead:
 

ston3r

Known Member
Senior Member

ston3r

Known Member
Senior Member
Jul 19, 2004
69
0
3,006
kuala lumpur
Visit site
ha..my one little difference with your,my car working normal with this error code.But only happen one time when i turn the aircond on ,aircond light on and no air comes out..the room temp meter and fuel meter no funtion..after 30min when i send my car to workshop and turn on my car again ,all the problem become normal ...i think i must hit the ghost..:confused:
By the way ,bro ..can you help me to ask your workshop ..what is the problem pls?
end up i can tell my machinast to check ,coz i know penang here very diffucult to fin the good machinast to find the problem...



i also just know be4 few day..bester then you ..haha..



Byran ,u must go workshop everyday lah,the only difference with our was u go workshop make $$$,we go workshop pay $$$....:banghead:
actually, this error code refers to the aircond controller, no other problems with my car. I can drive it as normal but no aircond, even all gauges were working 100%. I asked the foreman and he said that the aircond panel circuit was not sending electric signals out when i switched it on, thus no aircond, even the compressor was not working. He had to re-wire the aircond board to get electrical source from elsewhere. Where I did not find out because he didn't elaborate any further. Sorry, I also can't explain what he did. For me, as long as I get my aircond, I'm ok :biggrin:
 

stepwyew

Known Member
Senior Member

stepwyew

Known Member
Senior Member
Feb 10, 2006
448
15
1,518
1jz mean everyday also can fly like air asia..hehe.
after put 1jz can solve this error code but no money for maintenan,i dont want go to workshop everyday..haha


Brother,

Put 1jz where got go workshop everyday want ..........Go visit performance part work shop got lar hahahahahahahahahahaha........upgrade mar
 

Bl@cK-TeZZ@

500 RPM
Senior Member

Bl@cK-TeZZ@

500 RPM
Senior Member
Apr 15, 2006
837
6
1,518
Brother,

Put 1jz where got go workshop everyday want ..........Go visit performance part work shop got lar hahahahahahahahahahaha........upgrade mar
Brather....i know la u alwiz go woksyop quietly add on things without ppl knowing. How many 'bulls' d now under ur hood???:thefinger:
 

santa_cruzze

Junior Member

santa_cruzze

Junior Member
Jun 1, 2018
11
0
1
36
hi...up!!!....i know this old post...but suddenly my CEL came on while driving..the CEL stays around 5-15 seconds then off..so i took the car for diagnostic..only 1 error code found, it's the a/c solar sensor passenger side..fyi,i just did the timing belt replacement the day before..then this CEL came up...never happen b4 the timing belt change..is it related?....but the a/c still work & still cold..any ideas?