neo campro cps losing engine oil

  • Add your products now - we're testing a new Marketplace section to move over from the current forums version. Help by posting your items here: http://www.zerotohundred.com/shop/

demomode

Active Member
Senior Member

demomode

Active Member
Senior Member
Sep 26, 2009
30
0
1,506
Kuala Lumpur
as per title, my car using liquimoly 10-40 engine oil, oil went missing after 3 - 4K km drive after servicing with new oil. no visible white smoke & no leakage.

izzit engine oil burned bcoz of engine too hot? or other causes?

really need help
 

6UE5t

6,000 RPM
Senior Member

6UE5t

6,000 RPM
Senior Member
Oct 8, 2010
6,554
1,254
1,713
Kuala Lumpur
as per title, my car using liquimoly 10-40 engine oil, oil went missing after 3 - 4K km drive after servicing with new oil. no visible white smoke & no leakage.

izzit engine oil burned bcoz of engine too hot? or other causes?

really need help
Oil went missing means loosing how many liters?
 

demomode

Active Member
Senior Member

demomode

Active Member
Senior Member
Sep 26, 2009
30
0
1,506
Kuala Lumpur
Oil went missing means loosing how many liters?
after service, the oil dip shown at max level (oil level at the top marking) after 3 - 4k km ride, oil dip shown oil level is in between the max & min marking. not sure how many liters gone
 

6UE5t

6,000 RPM
Senior Member

6UE5t

6,000 RPM
Senior Member
Oct 8, 2010
6,554
1,254
1,713
Kuala Lumpur
after service, the oil dip shown at max level (oil level at the top marking) after 3 - 4k km ride, oil dip shown oil level is in between the max & min marking. not sure how many liters gone
You need to top it up until max level to know how many liters needed to top up back to max leh, so do that first. If just 0.5 ltr to top up then still rather normal, but if 1 liter or above then considered too much already.
 

jerrysiow

Known Member
Senior Member

jerrysiow

Known Member
Senior Member
Jan 3, 2012
403
146
543
Seremban
From what i understand, there is a slightly lower engine oil level after a new service with new oil filter. The engine oil went into the new oil filter causes the level of engine oil drop. You can follow what sifu 6UE5t's suggestion, top up the engine oil and monitor again.
 

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator
May 11, 2010
29,585
8,263
1,713
Petaling Jaya
From what i understand, there is a slightly lower engine oil level after a new service with new oil filter. The engine oil went into the new oil filter causes the level of engine oil drop. You can follow what sifu 6UE5t's suggestion, top up the engine oil and monitor again.
Normally mechanic after start engine and check for leaks, will Switch off, wait a while then check level again. This is to make sure level is correct after filling up oil filter also....:driver:
 

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator
May 11, 2010
29,585
8,263
1,713
Petaling Jaya
as per title, my car using liquimoly 10-40 engine oil, oil went missing after 3 - 4K km drive after servicing with new oil. no visible white smoke & no leakage.

izzit engine oil burned bcoz of engine too hot? or other causes?

really need help
If you are using same viscosity before and did not encounter this problem, on next oil change, change back to previous oil brand.
I have a friend encounter this problem before but for him is he changed from 5w-40 to a 5w-30. The viscosity for his car probably to thin, change back to 5w-40 then okay....:driver:
 

6UE5t

6,000 RPM
Senior Member

6UE5t

6,000 RPM
Senior Member
Oct 8, 2010
6,554
1,254
1,713
Kuala Lumpur
From what i understand, there is a slightly lower engine oil level after a new service with new oil filter. The engine oil went into the new oil filter causes the level of engine oil drop. You can follow what sifu 6UE5t's suggestion, top up the engine oil and monitor again.
Since when la I become sifu?? :confused:
 

6UE5t

6,000 RPM
Senior Member

6UE5t

6,000 RPM
Senior Member
Oct 8, 2010
6,554
1,254
1,713
Kuala Lumpur
Both you consider Sifu category edi la. I like your engine 2.5L V6, the sound and power are cun.
I think most will refer us as keyboard warrior......hhahhahahhahah:rofl:
Sifu touge with taufu like Takumi......lol:driver:
I tak pandai touge la, makan touge saja boleh. :biggrin:
Ya just keyboard warrior, only knows skin deep level. :biggrin:

This 2.5 V6 has no sound leh if full std, power also biasa biasa saja coz still normal family sedan. Kena tapau left right center by other cars already.
 

BFX73

Known Member
Senior Member

BFX73

Known Member
Senior Member
Oct 25, 2006
116
13
1,518
from CPS owner uses liqui molly...we heard the same issue and they topup EO every now n then...
change to other EO resolve the issue...but this is happening among CPS owner around me
 

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator
May 11, 2010
29,585
8,263
1,713
Petaling Jaya
from CPS owner uses liqui molly...we heard the same issue and they topup EO every now n then...
change to other EO resolve the issue...but this is happening among CPS owner around me
Long ago my Honda also tries using one oil with MoS2, also consume engine oil. Later switch back to former oil all okay.....lol:biggrin: