Car difficult to start..need advice..

  • Avatar Upload Issue Fixed! Have you been facing problems uploading avatars? Good news! it's fixed, so upload away!

Turf Grass

Active Member
Senior Member

Turf Grass

Active Member
Senior Member
Jan 19, 2007
26
1
1,503
Need advice from all sifus and if anyone ever had the same problem as mine. I drive 2002 Caldina GT4.Now days I found my GT4 very hard to start. Even worse during morning..I have to crank about 6 times (every crank ending with switch off all, pull key out, put back key in, ON ignition and crank again) to start the engine..if lucky after start, the engine idle like normal (no prob)..but sometimes (normally morning time) even after engine start, it die off again after few second and I have to crank again...I've been to few workshop and check..some mechanic says its because my plug is wet..(I look at it, only little bit wet by engine oil..too little to cause the prob.Even last time when my car was ok, my plug are always a little bit wet and only one plug..the other 3 are all OK..I use TRD spark plug).So I dont think its bcos of the spark plug. Another mechanic suggest to change the fuel pump (Caldina GT4 feul pump=RM1300!!). Maybe the motor is not strong enough to pump the feul from the tank to engine..once the car can start..the feul pump start pumping like normal (although i found it weird ;))

some other mechanic told me maybe its because of the timing valve..maybe a little bit loose (i dunno where is the timing valve honestly..i just angguk ;D).

One more thing i find weird is whenever my car is not moving and the engine is ON and the idle timing was OK, the timing will drop suddenly everytime I turn my steering wheel to right or left.Is like something that the shaft touch everytime it move that make the timing go low (although I dunno what it is)

btw, I just service the throtle body and spark plug, so I dont think its because of that.

Anybody care to share their experiance/opinion or good workshop for GT4 are most welcome because currently I dont know what cause the problem..and living like hell everytime want to start my car. Just waiting for the moment my car die off at the traffic light (touch wood)..

Thanks all in advance...appreciate it
 

mahfudz_mn

Known Member
Senior Member

mahfudz_mn

Known Member
Senior Member
Nov 22, 2004
181
21
3,018
Bukit Jalil
Visit site
there is a chip called the ignition module which controls the power from the distributor to the plug or something like that...since your fuel pump jalan, spark plugs are ok, and your engine is cranking...i suspect it is that thing...i had an '88 chevy blazer when i was in the states, replacing that thing solved my problem, it was located right in the distributor...dunno if now newer cars still have that ignition module...hope this helps
 

lucian^^Gk

Known Member
Senior Member

lucian^^Gk

Known Member
Senior Member
Sep 23, 2009
115
5
1,518
Sarawak
my 89 civic aso had tis kind of prob "very hard to start"
once car is start, had to pull button with the symbol like 'N' for around 3 min
then baru boleh jalan, if not it will die again after few seconds...
send to 3 workshop oleady. still not yet fixed...
 

kumar22mostwanted

1,500 RPM
Senior Member

kumar22mostwanted

1,500 RPM
Senior Member
Jan 9, 2010
1,562
152
1,663
HELL!!!
my 89 civic aso had tis kind of prob "very hard to start"
once car is start, had to pull button with the symbol like 'N' for around 3 min
then baru boleh jalan, if not it will die again after few seconds...
send to 3 workshop oleady. still not yet fixed...
could be coil problem last time my car also very hard to start then suddenly can start and drive no problem but it only lasted like 5 mins then it died in the middle of the road and then change coil problem gone
but dont change unless ur sure coz coil very xpensive the workshop i went to gave me a guarantee that if by changing coil the car still die they will refund my money back thats why i took the chance
 

autocrazee

1,000 RPM
Senior Member

autocrazee

1,000 RPM
Senior Member
Mar 14, 2011
1,088
11
638
Kuala Lumpur
www.fasmoto.com
My previous car had same problem. This electician at cheras (Yulek) installed a relay for the starter that made the problem go away. Cheap too. Maybe you have same problem. My engine was a 4AGZE tho.