Car decelerates while pushing the acceleration pedal

toozero

Junior Member

toozero

Junior Member
Aug 28, 2014
6
0
501
Kuala Lumpur
Hi guys, I owned Satria Neo 2006.

My car suddenly decelerates while pushing the acceleration pedal. The harder I push, my car will slowly down and almost stall. Like I pushing the brake instead of acceleration pedal. No lights come out.

-1st Case: I drove like 4 km then out of sudden it happen. My foot pushing the acceleration pedal but my car start to braking itself, tally to the forced I put on the acceleration pedal. I drop down the gear n accelerates again. No lights turn on. Safely home, tomorrow I drive, Its okay, nothing happen.

-2nd Case (after 1 month): My car did it again during accelerates at 4th gear. I drop to 3rd gear n hoping it turns well. But when I stop the car and start again, at 1st gear it even worst. Engine suddenly shut-off, check engine & oil lights brighten. but when I start the engine, the lights come off. but my car can move ~1km then engine shut-off. Safely home.

Called my mechanic, after 1 hour drive with him, nothing happen.then He suspected the acceleration pedal sensor. After he changed the acceleration pedal, I feel like I drive a different car. It feel light and more pick up.:driver:

Almost 1 month.So far the problem not happen yet. But If anyone knows/experienced the same situation as me, Do changing the acceleration pedal sensor solve the problem?because my mechanic also 50:50.

Thank you guys.:adore:
 

lsm1991

1,000 RPM
Senior Member

lsm1991

1,000 RPM
Senior Member
Sep 30, 2011
1,400
167
663
PJ
not really solving ur issue at all but i have suggestion for you to troubleshoot. If you have a cheapo obd II reader, you would probably be able to get the readings from that sensor. I know you can get the readings for that sensor by hooking the reader onto a saga sv cause i have tried that before. Problem with this suggestion is i also know that the cheapo obdII readers dont work for some early batches of proton personas (not sure bout the satria)
 

toozero

Junior Member

toozero

Junior Member
Aug 28, 2014
6
0
501
Kuala Lumpur
Thanks :burnout:
diagnosed my car today. Found 1 error only, my speed sensor already kaput. Do you guys know how much speed sensor for satria neo 1.3 manual? Since I did changed gas pedal before, I believe this one will solve the problem.:creep: