4G92 throttle body problem maybe?

jebatdex

Known Member
Senior Member

jebatdex

Known Member
Senior Member
Jun 19, 2011
430
18
518
Skudai, Johor
Hi there,

I got a problem with my 1996 1.6 Satria. Few months ago I changed my throttle body. I notice with my new throttle body, I got kind of vibration when my speed reaches about 95 kmh. Then, I took an alternative to increase its idle RPM from 1 (1000) to something like 1.25 and I can feel the vibration effect reduced a little bit. From my feeling, its not caused by tyres/mounting or that kind of thing, I feel like my engine does not have enough air coming into it. That's why I increase the idle RPM and hopefully more air can be sucked into the engine. But still, I can feel it now. I can (maybe) reduce the vibration more by increase my idle RPM a bit more, maybe to 1.5 but normally should have something like 1 idle RPM...right everyone? Hope someone can advise me on this. Thank you in advance.
 

Veloc

3,000 RPM
Senior Member

Veloc

3,000 RPM
Senior Member
May 19, 2010
3,234
991
1,713
Sabah
Bro... In my opinion, increasing idle speed won't effect your intake air when cruising or under acceleration. It's for idle only. Because even if u increase it, that is during idle time. When driving, the throttle openings and diameter is what counts. So the air flow into your engine is determined by the throttle diameter. And even if it is caused by not enough airflow, I don;t think the engine will vibrate. At most, you will just feel that you cannot accelerate further. Like it has reached its limit.

And, is your throttle body new, and clean?

Second, do you mean vibration or jerk?
 

jebatdex

Known Member
Senior Member

jebatdex

Known Member
Senior Member
Thread starter
Jun 19, 2011
430
18
518
Skudai, Johor
Yes, increasing idle speed won't effect your intake air when cruising or under acceleration but I can feel the jerk effect is reduced when I increase the idle RPM. huhu.. Maybe it can give effects in other way maybe?

No, the TB is used one. It has been cleaned before installed into my car.

Yes, it is jerk actually, not vibrate. The word didn't cross my mind before :stupid:

So, any suggestion on this? Please, really hope you guys can give some recommendations to rectify this problem. It is so irritated when I just have to cruise on highway no more than 90km/h plus I'm a very frequent traveler..
 
Last edited:

Veloc

3,000 RPM
Senior Member

Veloc

3,000 RPM
Senior Member
May 19, 2010
3,234
991
1,713
Sabah
Hmm... Unusual leh... Okat lets sort thing out here... Now there are 2 problems from what I understand.
1. Jerking
2. Cannot go beyond 90 km/h

It doesn't sounds like TB problem because no matter how dirty and clogged you TB is, I don't think it will reduce the hole size so much that it chokes the engine that way. Maybe check your injectors and ignition system? Satria 1.6 right? That model already got the port for diagnosis if i'm not mistaken. The problem is really subjective and it's hard to guess like that.

Any sifus can contribute?
 

jebatdex

Known Member
Senior Member

jebatdex

Known Member
Senior Member
Thread starter
Jun 19, 2011
430
18
518
Skudai, Johor
Hmm... Unusual leh... Okat lets sort thing out here... Now there are 2 problems from what I understand.
1. Jerking
2. Cannot go beyond 90 km/h

It doesn't sounds like TB problem because no matter how dirty and clogged you TB is, I don't think it will reduce the hole size so much that it chokes the engine that way. Maybe check your injectors and ignition system? Satria 1.6 right? That model already got the port for diagnosis if i'm not mistaken. The problem is really subjective and it's hard to guess like that.

Any sifus can contribute?
I can go beyond 90 km/h (about 2500 RPM), but I will start to feel the jerking..
 

Veloc

3,000 RPM
Senior Member

Veloc

3,000 RPM
Senior Member
May 19, 2010
3,234
991
1,713
Sabah
Try diagnose and consider other things la... Maybe the other part has problem all along but just got worse right after you change the TB. By coincidence? Who know... Sound more like ignition or injector rather than TB already this one...
 

intervener

Active Member
Senior Member

intervener

Active Member
Senior Member
Oct 18, 2008
26
4
1,503
Do a dignostic (MUT) test to find out the fault (if your Check Engine light came out) and from my experience it may be your ECU, MAP Flow Sensor (little black box after your air-filter box) or there may be a hole in one of those vacuum hose that causing the problem.

Good luck
 

Veloc

3,000 RPM
Senior Member

Veloc

3,000 RPM
Senior Member
May 19, 2010
3,234
991
1,713
Sabah
Yeah the MAP sensor also a possibility...
 

jebatdex

Known Member
Senior Member

jebatdex

Known Member
Senior Member
Thread starter
Jun 19, 2011
430
18
518
Skudai, Johor
Just changed spark plugs and distributor.

I remember, long before I went to Proton, one of the mechanic said if there is something happened to my TB (like changing a new one), I need to bring my car to any Proton service center then they will reset the setting (I think he meant ECU). Is that right? Last time (2 years ago), he charged me RM50 for resetting it.
 

Veloc

3,000 RPM
Senior Member

Veloc

3,000 RPM
Senior Member
May 19, 2010
3,234
991
1,713
Sabah
ECU reset for RM50? Just taking out the battery terminals for 30 mins?
 

jebatdex

Known Member
Senior Member

jebatdex

Known Member
Senior Member
Thread starter
Jun 19, 2011
430
18
518
Skudai, Johor
Went to Proton Edar today at Section 13 PJ and did ECU reset. Most of the jerking problem solved :proud: but I think I still can feel a little when cruising.. A friend of mine suggest me to check the spark plug cable as well? Is there any possibility the problem caused by plug cable? How about fuel pump? It's a 15-year-old car and maybe it is time to change the fuel pump? Any suggestion on this?