toyota 4age silvertop

Discussion in 'Introduction and Newbies' started by Asif, Mar 1, 2018.

  1. Asif

    Asif New Member

    Joined:
    Mar 1, 2018
    Messages:
    3
    Likes Received:
    1
    Hello everyone.
    I'm new to this page,.
    I'm a mauritian and i cant write english well,.
    I just needed some help from you guys,.
    I have a toyota 4age silvertop,.my problem is high fuel consumption,i recently swap this engine on my corolla KE 72 wagon to pickup conversion,and i'm having much trouble with the engine..
    Earlier,i installed 2" straight pipe on the vehicle,with no resonator,nor catalytic,and the idle sounded rough,like rotary engine,.
    Later i changed back to only a silencer at the end,
    But still having rough idling
    Black smoke and a having smell like unburnt fuel coming out of the exhaust,
    In the begining,i ran on stock engine,but later i tried to disconect the air flow meter,and not having much diference on engine behaviour,so i remove the intake box and let it run on the ITBs like blacktop,.
    The engine runs well without the air flow meter,but the fuel consumption is still high..
    Can you guys help
    Thanks
     
  2. Asif

    Asif New Member

    Joined:
    Mar 1, 2018
    Messages:
    3
    Likes Received:
    1
    I posted photos of the car and the engine,chek it out.
     

    Attached Files:

  3. Izso

    Izso Boooooossst
    Helmet Clan Moderator

    Joined:
    Mar 28, 2004
    Messages:
    13,530
    Likes Received:
    6,007
    Hi Asif, did you check that your spark plugs are in good condition?
     
  4. Asif

    Asif New Member

    Joined:
    Mar 1, 2018
    Messages:
    3
    Likes Received:
    1
    Hii,.ya the sparks plugs are good,...but when i remove them,they are all black,..like carbon formation on the tip,.
     
  5. Izso

    Izso Boooooossst
    Helmet Clan Moderator

    Joined:
    Mar 28, 2004
    Messages:
    13,530
    Likes Received:
    6,007
    sounds like you're running too rich. Is the ECU aftermarket or stock?
     
  6. alcyon

    alcyon Active Member

    Joined:
    Sep 13, 2015
    Messages:
    470
    Likes Received:
    53
    yOU NEED the AFM otherwise the engine wont know how much air its getting. Your AFM could be faulty.
    http://www.cygnusx1.net/Supra/Library/TSRM/MK3/manual.aspx?S=FI&P=94
    Look at page FI-94, take out your multimeter with continuity measurement and measure the pins as indicated. Note you may have a different set of values, becuase this is for the 7M engine, but you will get an idea if some pins arent giving out any readings.
     
  7. vr2turbo

    vr2turbo Moderator
    Helmet Clan Moderator

    Joined:
    May 11, 2010
    Messages:
    27,212
    Likes Received:
    7,864
    Firstly, welcome to ZTH forum....

    With faulty or no AFM, the ECU must be fueling maximum all the while, that is why high FC and plenty of soot and carbon....
     
  8. Asif

    Asif New Member

    Joined:
    Mar 1, 2018
    Messages:
    3
    Likes Received:
    1
    Running on stock.
     

    Attached Files:

  9. Asif

    Asif New Member

    Joined:
    Mar 1, 2018
    Messages:
    3
    Likes Received:
    1
    But the fact is,even earlier with the AFM on,the sparks plugs used to be balck in colour when removed,..
    And when i run the car,when i pressed the accelerator pedal,it goes on smoothly,but when i release the pedal slowly,the car like jumps a little faster for a second and then decelerate.
     
  10. Asif

    Asif New Member

    Joined:
    Mar 1, 2018
    Messages:
    3
    Likes Received:
    1
    Yaa thanks,but i dont have the multimeter for the moment,as soon as i get it i will check the continuity,.
     
    #10 Asif, Mar 2, 2018
    Last edited: Mar 2, 2018
  11. Asif

    Asif New Member

    Joined:
    Mar 1, 2018
    Messages:
    3
    Likes Received:
    1
    I was wondering,if my injectors are stuck open,would it run a rough idling and when reving it runs good?
     
  12. alcyon

    alcyon Active Member

    Joined:
    Sep 13, 2015
    Messages:
    470
    Likes Received:
    53
    I suggest you look on toymods.au forums. I think your problem could have been discussed there.
     
  13. Asif

    Asif New Member

    Joined:
    Mar 1, 2018
    Messages:
    3
    Likes Received:
    1
    I looked everywhere,i'm trying to solve this case for nearly 5 months,.
     
  14. Asif

    Asif New Member

    Joined:
    Mar 1, 2018
    Messages:
    3
    Likes Received:
    1
    I got the multimeter today,cheked the airflow meter,and indeed,having no reading on any terminal,..
    I'll have to look for one and chek run the engine with,.but the problem is,its rare to find an AFM here
    Have to drive around the entire island
     
  15. alcyon

    alcyon Active Member

    Joined:
    Sep 13, 2015
    Messages:
    470
    Likes Received:
    53
  16. vr2turbo

    vr2turbo Moderator
    Helmet Clan Moderator

    Joined:
    May 11, 2010
    Messages:
    27,212
    Likes Received:
    7,864
    As bro. alcyon posted, get from overseas......
     
  17. Asif

    Asif New Member

    Joined:
    Mar 1, 2018
    Messages:
    3
    Likes Received:
    1
    Thanks for the link,..
    But was just wondering if the AFM can be repaired,
     
  18. Asif

    Asif New Member

    Joined:
    Mar 1, 2018
    Messages:
    3
    Likes Received:
    1
    Yaaaa but can it be repaired??
     
  19. vr2turbo

    vr2turbo Moderator
    Helmet Clan Moderator

    Joined:
    May 11, 2010
    Messages:
    27,212
    Likes Received:
    7,864
    That will depends on what is wrong with it. Any mechanic you know can check on it?
     
  20. alcyon

    alcyon Active Member

    Joined:
    Sep 13, 2015
    Messages:
    470
    Likes Received:
    53
    You have nothing to lose anyway since its spoilt. But be be aware there isnt much you can to do the AFM. certainly do not spray the board with any cleaners. However I doubt you can fix it as if the track is worn off you can't shift the brass arm like Bosch units.
     

Share This Page