problem evo3(with 4g67 block)--- video attch

  • Updates: Thread Thumbnails added to all forum channels / Explore Similar Threads after reading any post / Dark Mode selectable via header lightbulb / Bigger text / Navigation bar Updated / Try Dark Mode - Select Light / Dark from the footer area / Hi All, the forums have just been upgraded, please bear with us while it is being improved as we speak - May 19 2020 0000hrs

guest

Senior Member
Senior Member
Jan 22, 2007
346
20
1,516
Kota Kinabalu
ok...somehow my car began to make problem again....now car when start in idle...can hear "pop..pop"...sound from the exhaust and the car like wanna die trying to breath..when i start and drive the car..the car cannot go to high rpm...worse top speed only 120km/h(that also feels like the engine running about 180km/h already)....so i tot the problem maybe caused by bad spark plug...so i change the ori HKS spark plug to borch spark plug(new)...well bad idea...its getting worse then before.....b4 i bring to the mech...i wanna know what causing this problem....plze share....tq:bawling:

engine spec: evo3 with 4g67 block,arp head screw, new piston ring and bearing(running around 1100km only, anything else is standard.....


wiraevo32.wmv - YouTube
 
Last edited:

guest

Senior Member
Senior Member
Jan 22, 2007
346
20
1,516
Kota Kinabalu
ohh...is bcoz of damaged piston or just about fuel pump or cable plug...coz just afraid 2moro bring to mech bcoz of piston damage...aiya.....money2...the engine wanna die gegar2 worr.....btw my block is just overhauled.....new piston rings all etc.....
 

ehdrian

I Don't Care!
Senior Member
Dec 14, 2006
3,312
280
1,683
Penang
I dun really know wat caused yr engine to be like dat..I had a faulty fuel pump before but my idling was stable, unlike urs, just dat i can't accelerate smoothly..engine choke when i try to floor the pedal..your engine is still running in, did u whack yr car ade?..
 

guest

Senior Member
Senior Member
Jan 22, 2007
346
20
1,516
Kota Kinabalu
nope...no wacking coz still below 5k.....afraid piston damage so running below 4k of rpm....err....suddenly like that wor.....aiya....
 

ylkien

Senior Member
Senior Member
May 17, 2005
499
3
1,516
KL/PJ
i think it could be somewhere along the intake or ECU.

Maybe can check these first :

1) Intake air sensor, filter, and hose.
2) Throttle body motor & sensor
 

C99D-MMC5537

Senior Member
Senior Member
Jan 9, 2008
287
78
1,528
ignition not stable. try check all the connector from plug cable, to coil, to power unit and so on.
 

guest

Senior Member
Senior Member
Jan 22, 2007
346
20
1,516
Kota Kinabalu
ignition not stable. try check all the connector from plug cable, to coil, to power unit and so on.
yeah..i also suspected the cable coz...b4 i change to borch spark plug....this problem not really accour badly...but after i change to new spark plug...this getting worse...maybe bcoz of i already mess up with the cable?can any one tell me the running number for each cable to the engine?
 

guest

Senior Member
Senior Member
Jan 22, 2007
346
20
1,516
Kota Kinabalu
sure ...the timing for the belting is a bit off....i think around 2 gigi.....dunno how lari or lastime the other mech didn't do marking properly so the problem become worse and worse.....the lower belting also lari timing.....argg...hope will be ok already......cheers....

---------- Post added at 09:42 PM ---------- 6 hour anti-bump limit - Previous post was at 09:20 PM ----------

ohh ya the mech heard that the engine is knoking...thats y he check the timing and belting....
 

guest

Senior Member
Senior Member
Jan 22, 2007
346
20
1,516
Kota Kinabalu
car problem again.....guys...i would like to know...when i race my engine in start up(to high rpm) (as normal before this rpm will go up and down back to 1k rpm)....but mine goes down to 300 then bounce back 1k..seems like car vibrate wanna die/shut down.....same as when i wack my car each gear....rpm will go down to nearly 300rpm and bounce up to 1k(feels car wanna die or shut down)...y ah?

2nd.-my rear wheel now makan dalam....looks like tayar terkangkan..so i do "pressing"...after one week tayar seems kaangkang again,,,do i need rear adjustable camber?

3rd. why my car when i tarik2 feels like engine longgar?mounting still in good conditon...feels like when i change gear engine bounce back and front...

4th. when i low gear(1st gear) time heavy jem...car drive slow in first gear like terhantuk2...or jerking...y?when car like terhantuk2 need to press clutch then ok...2nd and high gear seems ok....

any friends wanna share?tq
 
Last edited:

guest

Senior Member
Senior Member
Jan 22, 2007
346
20
1,516
Kota Kinabalu
ok..thanks bro...1st problem kind of solve already...im using sheepdog BOV..lastime i set the soft hard...coz they said if set hard...bov will sound like tengkukur....but sadly its compression surge..so i set back too...i mean tooooo soft..so BOV leaking..and now i dunno how to get back the previous setting...haiya.....

2nd.-my rear wheel now makan dalam....looks like tayar terkangkan..so i do "pressing"...after one week tayar seems kaangkang again,,,do i need rear adjustable camber?- i already add 'sim' and done pressing...ok already....

3rd. why my car when i tarik2 feels like engine longgar?mounting still in good conditon...feels like when i change gear engine bounce back and front...- this one still not solve...hiya....

4th. when i low gear(1st gear) time heavy jem...car drive slow in first gear like terhantuk2...or jerking...y?when car like terhantuk2 need to press clutch then ok...2nd and high gear seems ok....- this also not solve...haiya...
 

DanzEterna

Moderator
Moderator
Senior Member
Nov 1, 2007
15,916
3,371
1,713
PJ
www.primeperdanaclub.com
3rd. why my car when i tarik2 feels like engine longgar?mounting still in good conditon...feels like when i change gear engine bounce back and front...- this one still not solve...hiya....
** try installing the torque damper.
Original japan engine torque damper honda - Car Accessories & Parts for sale Kelantan - Mudah.my

4th. when i low gear(1st gear) time heavy jem...car drive slow in first gear like terhantuk2...or jerking...y?when car like terhantuk2 need to press clutch then ok...2nd and high gear seems ok....- this also not solve...haiya...
**u using 4 0r 5 puck clutch plate? its like that anyways....like a jerking feel rite.
 

guest

Senior Member
Senior Member
Jan 22, 2007
346
20
1,516
Kota Kinabalu
3rd. why my car when i tarik2 feels like engine longgar?mounting still in good conditon...feels like when i change gear engine bounce back and front...- this one still not solve...hiya....
** try installing the torque damper.
Original japan engine torque damper honda - Car Accessories & Parts for sale Kelantan - Mudah.my

4th. when i low gear(1st gear) time heavy jem...car drive slow in first gear like terhantuk2...or jerking...y?when car like terhantuk2 need to press clutch then ok...2nd and high gear seems ok....- this also not solve...haiya...
**u using 4 0r 5 puck clutch plate? its like that anyways....like a jerking feel rite.
thanks bro danz....will try to search more info about the torque damper.....btw..im using standard clutch...ehehehe....

---------- Post added at 07:37 PM ---------- 6 hour anti-bump limit - Previous post was at 07:35 PM ----------

ur car 2wd or 4wd? come out yamcha wit us la...we got few 4G63 kakis here....0168417327

sure kenny...hehehe...i have the 4wd system at home but now im using 2wd setup....i think need to see u la kenny so u can give some help about my car problem....:adore:hehehe....

---------- Post added at 09:40 PM ---------- 6 hour anti-bump limit - Previous post was at 07:37 PM ----------

May i know where can i buy this torque damper for my wira evo engine?