Civic EG launch control problem

  • Updates: New Bump Button / Bigger Fonts / Thread Thumbnails added to all forum channels / Explore Similar Threads after reading any post / Dark Mode selectable via header lightbulb / Bigger text / Navigation bar Updated / Try Dark Mode - Select Light / Dark from the footer area / Hi All, the forums have just been upgraded, please bear with us while it is being improved as we speak - May 19 2020 0000hrs (Post your feedback here: FAQ Help)

andrew777

5 Year | Silver

andrew777

5 Year | Silver
Sep 22, 2014
9
0
501
Kuala Lumpur
Dear all,

My civic eg running on p30 ecu neptune chipped with launch control function.
On recent drive, Vtec kick in on 5.8k rpm as usual, after that the car engine remain at full throttle, and if the car is idling, it also on 4k rpm launch control even i didnt press accelerator.
Visible check no vacum leak, throttle cable all fine, and once i unplug the map sensor, rpm remain on 2k rpm.
Anyone have clue/solution for this?

Thanks in advance.
 

Izso

Boooooossst
Helmet Clan
Moderator

Izso

Boooooossst
Helmet Clan
Moderator
Mar 28, 2004
14,733
6,218
3,213
KL
I'm not clear on what the issue is. This is you trying to launch or is this idle?

Isn't the P30 Neptune a stock ECU with some extra add ons? The launch control rechip didn't do properly?
 

Tom

15 Year | Platinum
Helmet Clan

Tom

15 Year | Platinum
Helmet Clan
Jul 6, 2000
5,342
3,116
3,213
Kuala Lumpur
Dear all,

My civic eg running on p30 ecu neptune chipped with launch control function.
On recent drive, Vtec kick in on 5.8k rpm as usual, after that the car engine remain at full throttle, and if the car is idling, it also on 4k rpm launch control even i didnt press accelerator.
Visible check no vacum leak, throttle cable all fine, and once i unplug the map sensor, rpm remain on 2k rpm.
Anyone have clue/solution for this?

Thanks in advance.
The launch control function cuts throttle or ignition during full throttle,
if your throttle is still cable operated then it shouldn't have anything to do with the launch control or chip.

Could it be the floor mat, or just a stuck cable?
 

andrew777

5 Year | Silver

andrew777

5 Year | Silver
Sep 22, 2014
9
0
501
Kuala Lumpur
I'm not clear on what the issue is. This is you trying to launch or is this idle?

Isn't the P30 Neptune a stock ECU with some extra add ons? The launch control rechip didn't do properly?
The scenario is like these:
I cruising on highway, and i kick in vtec to overtake a car, after that, i feel the car keep throttle even my right foot didnt press on the accelerator, then i have to emergency stop by roadside, and turn off the engine, when i restart the engine, the engine is in full throttle
 

andrew777

5 Year | Silver

andrew777

5 Year | Silver
Sep 22, 2014
9
0
501
Kuala Lumpur
The launch control function cuts throttle or ignition during full throttle,
if your throttle is still cable operated then it shouldn't have anything to do with the launch control or chip.

Could it be the floor mat, or just a stuck cable?
Ya, i checked the throttle body cable, is in normal condition, and not floor mat, really no idea what to check next...
 

Izso

Boooooossst
Helmet Clan
Moderator

Izso

Boooooossst
Helmet Clan
Moderator
Mar 28, 2004
14,733
6,218
3,213
KL
The scenario is like these:
I cruising on highway, and i kick in vtec to overtake a car, after that, i feel the car keep throttle even my right foot didnt press on the accelerator, then i have to emergency stop by roadside, and turn off the engine, when i restart the engine, the engine is in full throttle
That's seriously weird.

Your car sounds it has a stuck WOT throttle body. But it's not the cable right? Did you port the TB? Butterfly not closing properly?
 

andrew777

5 Year | Silver

andrew777

5 Year | Silver
Sep 22, 2014
9
0
501
Kuala Lumpur
That's seriously weird.

Your car sounds it has a stuck WOT throttle body. But it's not the cable right? Did you port the TB? Butterfly not closing properly?
Yes, not the cable, i try pull the cable and it works fine, and then i dismantle air filter hose to TB, try to see if anything stuck inside TB or the butterfly flap got any strange, but found nothing.
 

sweelt

Well-Known Member

sweelt

Well-Known Member
Nov 6, 2016
2,183
203
163
Penang
Yes, not the cable, i try pull the cable and it works fine, and then i dismantle air filter hose to TB, try to see if anything stuck inside TB or the butterfly flap got any strange, but found nothing.
did you dismantle TB recently ?
Happened to me during diy clean tb. Found out i fix gasket in wrong orientation, gasket tip interrupting tb movement.
 

vr2turbo

15 Year | Platinum
Helmet Clan
Moderator

vr2turbo

15 Year | Platinum
Helmet Clan
Moderator
May 11, 2010
29,247
8,169
1,713
Petaling Jaya
did you dismantle TB recently ?
Happened to me during diy clean tb. Found out i fix gasket in wrong orientation, gasket tip interrupting tb movement.
Ah, makes sense. Mine was when I tried fitting K&N air filter last time, the adapter, at one corner less than 1mm block, the acceleration all haywire.....lol
 

VtecBear93

New Member

VtecBear93

New Member
Apr 20, 2020
5
0
1
27
Hey guys..I'm very new to Neptune chip and new to this forum as well.. like what are some of the features that we can do with? Apart from the launch control is like basically pushing down the throttle.. like what are other things that we can do?
 

Izso

Boooooossst
Helmet Clan
Moderator

Izso

Boooooossst
Helmet Clan
Moderator
Mar 28, 2004
14,733
6,218
3,213
KL
This one i havent check, tmr morning i go have a look, tks for your suggestion too
i doubt the solenoid has anything to do with the rev hold that high. Potentially you have a leaky vacuum somewhere or the rechip is starting to fail. Does it happen only when it's hot?

Hey guys..I'm very new to Neptune chip and new to this forum as well.. like what are some of the features that we can do with? Apart from the launch control is like basically pushing down the throttle.. like what are other things that we can do?
welcome to the forum. I can't comment on the neptune rechip as I haven't done it before. You have it already or you looking to do it?
 

VtecBear93

New Member

VtecBear93

New Member
Apr 20, 2020
5
0
1
27
i doubt the solenoid has anything to do with the rev hold that high. Potentially you have a leaky vacuum somewhere or the rechip is starting to fail. Does it happen only when it's hot?


welcome to the forum. I can't comment on the neptune rechip as I haven't done it before. You have it already or you looking to do it?
Thanks bruh! No, I've rechipped my P30 ECU with Neptune alrd..At the moment during this MCO, I'm actually exploring on like what are the features this Neptune has..like as I've mentioned, launch control is one of em. Apart from that like what else? I've been searching everywhere but couldn't find any information..though I saw in YouTube, Neptune has a security feature with the correct input code of throttle pedal and brake to enable the car to start upon ignition.. that's pretty interesting..

Was wondering if anybody know what else we can play/explore around with it?
 

Izso

Boooooossst
Helmet Clan
Moderator

Izso

Boooooossst
Helmet Clan
Moderator
Mar 28, 2004
14,733
6,218
3,213
KL
Thanks bruh! No, I've rechipped my P30 ECU with Neptune alrd..At the moment during this MCO, I'm actually exploring on like what are the features this Neptune has..like as I've mentioned, launch control is one of em. Apart from that like what else? I've been searching everywhere but couldn't find any information..though I saw in YouTube, Neptune has a security feature with the correct input code of throttle pedal and brake to enable the car to start upon ignition.. that's pretty interesting..

Was wondering if anybody know what else we can play/explore around with it?
actually didn't the shop that did the rechip tell you the features?
 

Izso

Boooooossst
Helmet Clan
Moderator

Izso

Boooooossst
Helmet Clan
Moderator
Mar 28, 2004
14,733
6,218
3,213
KL
Uh nope, he told me to explore it...LOL..perhaps I should go back asking him again.. hahahaha
Wow... can I sell you something too bro? Guaranteed to make your car faster. But I'm not gonna tell you how and just charge you RM2k without telling you anything.

:biggrin: